您的位置:首页 > 其它

POJ 3255 - Roadblocks(次短路)

2017-11-27 11:09 531 查看
Roadblocks

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 16533 Accepted: 5829
Description

Bessie has moved to a small farm and sometimes enjoys returning to visit one of her best friends. She does not want to get to her old home too quickly, because she likes the scenery along the way. She has decided to take the second-shortest rather than the
shortest path. She knows there must be some second-shortest path.

The countryside consists of R (1 ≤ R ≤ 100,000) bidirectional roads, each linking two of the N (1 ≤ N ≤ 5000) intersections, conveniently numbered 1..N. Bessie starts at intersection 1, and her friend (the destination)
is at intersection N.

The second-shortest path may share roads with any of the shortest paths, and it may backtrack i.e., use the same road or intersection more than once. The second-shortest path is the shortest path whose length is longer than the shortest path(s) (i.e., if
two or more shortest paths exist, the second-shortest path is the one whose length is longer than those but no longer than any other path).

Input

Line 1: Two space-separated integers: N and R 

Lines 2..R+1: Each line contains three space-separated integers: A, B, and D that describe a road that connects intersections A and B and has length D (1 ≤ D ≤ 5000)
Output

Line 1: The length of the second shortest path between node 1 and node N
Sample Input
4 4
1 2 100
2 4 200
2 3 250
3 4 100

Sample Output
450

Hint

Two routes: 1 -> 2 -> 4 (length 100+200=300) and 1 -> 2 -> 3 -> 4 (length 100+250+100=450)
Source

USACO 2006 November Gold
题意:

要绝对意义的次短路,一定要比最短路短

#include <string>
#include <string.h>
#include <iostream>
#include <queue>
#include <math.h>
#include <stdio.h>
#include <algorithm>
using namespace std;
#define LL long long
const int maxn = 200000+55;
const int inf = 0x3f3f3f3f;
int n,m;
int head[5555],nxt[maxn],to[maxn],sz=0,w[maxn];
int dis[5555][2];
typedef pair<int, int> pi;
void dij()
{
for(int i=1;i<=n;i++) dis[i][0]=dis[i][1]=inf;
priority_queue&l
e824
t;pi,vector<pi>,greater<pi> >q;
q.push(make_pair(0, 1));
while(!q.empty()){
int now=q.top().first;
int u=q.top().second;
q.pop();
if(dis[u][1]<now) continue;
for(int i=head[u];~i;i=nxt[i]){
int v=to[i];
int ww=w[i];
if(now+ww<dis[v][0]){
dis[v][1]=now+ww;
swap(dis[v][1], dis[v][0]);
q.push(make_pair(dis[v][0], v));
}else if(now+ww<dis[v][1]&&now+ww>dis[v][0]){
dis[v][1]=now+ww;
q.push(make_pair(dis[v][1],v));
}
}
}
printf("%d\n",dis
[1]);
}
int main()
{
scanf("%d %d",&n,&m);
for(int i=1;i<=n;i++) head[i]=-1;
for(int i=1;i<=m;i++){
int u,v,ww;
scanf("%d %d %d",&u,&v,&ww);
nxt[sz]=head[u],to[sz]=v,w[sz]=ww,head[u]=sz++;
nxt[sz]=head[v],to[sz]=u,w[sz]=ww,head[v]=sz++;
}
dij();

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: