您的位置:首页 > 产品设计 > UI/UE

Pick The Sticks UESTC - 1218 0-1背包变形

2017-11-26 21:23 399 查看
题目链接

The story happened long long ago. One day, Cao Cao made a special order called “Chicken Rib” to his army. No one got his point and all became very panic.

However, Cao Cao himself felt very proud of his interesting idea and enjoyed it.

Xiu Yang, one of the cleverest counselors of Cao Cao, understood the command Rather than keep it to himself, he told the point to the whole army. Cao Cao got very angry at his

cleverness and would like to punish Xiu Yang. But how can you punish someone because he’s clever? By looking at the chicken rib, he finally got a new idea to punish Xiu Yang.

He told Xiu Yang that as his reward of encrypting the special order, he could take as many gold sticks as possible from his desk. But he could only use one stick as the container.

Formally, we can treat the container stick as an LL length segment. And the gold sticks as segments too. There were many gold sticks with different length aiai and value vivi.

Xiu Yang needed to put these gold segments onto the container segment. No gold segment was allowed to be overlapped. Luckily, Xiu Yang came up with a good idea. On the two sides

of the container, he could make part of the gold sticks outside the container as long as the center of the gravity of each gold stick was still within the container. This could

help him get more valuable gold sticks.

As a result, Xiu Yang took too many gold sticks which made Cao Cao much more angry. Cao Cao killed Xiu Yang before he made himself home. So no one knows how many gold sticks

Xiu Yang made it in the container.

Can you help solve the mystery by finding out what’s the maximum value of the gold sticks Xiu Yang could have taken?

Input

The first line of the input gives the number of test cases, TT(1≤T≤1001≤T≤100). TT test cases follow.

Each test case start with two integers, NN(1≤N≤10001≤N≤1000) and LL(1≤L≤20001≤L≤2000), represents the number of gold sticks and the length of the container stick. NN lines follow.

Each line consist of two integers, aiai(1≤ai≤20001≤ai≤2000) and vivi(1≤vi≤1091≤vi≤109), represents the length and the value of the ithith gold stick.

Output

For each test case, output one line containing Case #x: y, where xx is the test case number (starting from 11) and yy is the maximum value of the gold sticks Xiu Yang

could have taken.

Sample Input

4

3 7

4 1

2 1

8 1

3 7

4 2

2 1

8 4

3 5

4 1

2 2

8 9

1 1

10 3

Sample Output

Case #1: 2

Case #2: 6

Case #3: 11

Case #4: 3

Hint

In the third case, assume the container is lay on xx-axis from 00 to 55. Xiu Yang could put the second gold stick center at 00 and put the third gold stick center at 55,

so none of them will drop and he can get total 2+9=112+9=11 value. In the fourth case, Xiu Yang could just put the only gold stick center on any position of [0,1][0,1],

and he can get the value of 33.

刚开始的思路是对DP加两个标记,分别为左边和右边,dp
[m][2][2],但一直wa,后来改成 dp
[m][3]就过了,这里的思想是,可以把左边右边不影响结果,其影响的只是占用的长度,所以DP加一维表示现在有几个占用即可.

#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
int n,m;
int a[1005];
ll v[1005];
ll dp[2][4015][3];
int main()
{
//    freopen("data.txt","r",stdin);
//    ios_base::sync_with_stdio(false);
int T;
int mid;
scanf("%d",&T);
for(int cas = 1; cas <= T ;cas++)
{
memset(dp,0,sizeof(dp));
memset(a,0,sizeof(a));
memset(v,0,sizeof(v));
scanf("%d %d",&n,&m);
m*=2;
ll maxx = 0;
for(int i=1;i<=n;i++)
{
scanf("%d %lld",&a[i],&v[i]);
a[i]*=2;
maxx=max(v[i],maxx);
}

for(int i=1;i<=n;i++)
{
mid = a[i]/2;
for(int j=0;j<=m;j++)
{
dp[i&1][j][0] = dp[(i+1)&1][j][0];
dp[i&1][j][1] = dp[(i+1)&1][j][1];
dp[i&1][j][2] = dp[(i+1)&1][j][2];

}

for(int j=mid;j<=m;j++)
{
if(j>=a[i])
{
dp[i&1][j][0] = max(dp[i&1][j][0],dp[(i+1)&1][ j-a[i] ][0] + v[i] );
dp[i&1][j][1] = max(dp[i&1][j][1],dp[(i+1)&1][ j-a[i] ][1] + v[i] );
dp[i&1][j][2] = max(dp[i&1][j][2],dp[(i+1)&1][ j-a[i] ][2] + v[i] );
}

dp[i&1][j][1] = max(dp[i&1][j][1],dp[(i+1)&1][j-mid][0] +v[i]);//状态转移
dp[i&1][j][2] = max(dp[i&1][j][2],dp[(i+1)&1][j-mid][1] +v[i]);//状态转移

}
}

ll ans = 0;
ans = max(ans,dp[n&1][m][0]);
ans = max(ans,dp[n&1][m][1]);
ans = max(ans,dp[n&1][m][2]);

ans = max(ans,maxx);
printf("Case #%d: %lld\n",cas,ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: