您的位置:首页 > 其它

Anniversary party(树形dp 基础题)

2017-11-26 10:07 323 查看
题目:Anniversary party



There is going to be a party to celebrate the 80-th Anniversary of the Ural State University. The University has a hierarchical structure of employees. It means that the supervisor relation forms a tree rooted at the
rector V. E. Tretyakov. In order to make the party funny for every one, the rector does not want both an employee and his or her immediate supervisor to be present. The personnel office has evaluated conviviality of each employee, so everyone has some number
(rating) attached to him or her. Your task is to make a list of guests with the maximal possible sum of guests' conviviality ratings.


Input

Employees are numbered from 1 to N. A first line of input contains a number N. 1 <= N <= 6 000. Each of the subsequent N lines contains the conviviality rating of the corresponding employee. Conviviality rating is an integer number in a range from -128 to 127.
After that go T lines that describe a supervisor relation tree. Each line of the tree specification has the form:

L K

It means that the K-th employee is an immediate supervisor of the L-th employee. Input is ended with the line

0 0

Output

Output should contain the maximal sum of guests' ratings.

Sample Input

7

1

1

1

1

1

1

1

1 3

2 3

6 4

7 4

4 5

3 5

0 0

Sample Output

5



题意:有一个庆典晚会,想邀请一些人来参加。每个人都有自己的值(权值),问如果两个人之间有直接的上下级关系,那么他们中只能来一个,求请来的一部分人的最大权值是多少。

输入:

有n个人,接下来给出的是n个人的权值,在接下来n行给出的是l,k,k是l的上司,l与k不能同时出现,求如何取能得到最大权值。

思路:树形dp求解。

定义一个二维dp数组来记录价值,dp[i][0]表示i出席的最大权值,dp[i][1]表示i不出席时的最大权值。

用vector数组建立树,用于记录父亲和孩子的连接。

状态转移方程:

dp[i][0] += dp[son][1];

dp[i][1] += max(dp[son][0],dp[son][1]);

源代码:

#include <iostream>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <stdio.h>
#include <vector>
using namespace std;
int dp[6005][2];//dp[i][0]是i被邀请的快乐值,1就是不被邀请的快乐值。
int v[6005];//每个人的快乐值
bool visit[6005];//dp过程中用于记录是否经过过该节点
vector <int> tree[6005];//用于储存某一个节点作为父节点它的子节点的号码
int son[6005];//该节点是多少个父节点的子节点。
void tree_dp(int now){
dp[now][0] = v[now];
dp[now][1] = 0;
visit[now] = 1;
for (int i = 0; i < tree[now].size(); i++){
// cout << tree[i].size()-1 << endl;
int Son = tree[now][i];
if (visit[Son] == 1)
continue;
tree_dp(Son);
dp[now][0] += dp[Son][1];
dp[now][1] += max(dp[Son][0],dp[Son][1]);
}
}
int main(){
int N;
while (scanf("%d",&N)!=EOF){
memset(dp,0,sizeof(dp));
memset(v,0,sizeof(v));
memset(visit,0,sizeof(visit));
memset(son,0,sizeof(son));
for (int i = 1; i <= N; i++)
tree[i].clear();
for (int i = 1; i <= N; i++){
scanf("%d",&v[i]);
}
int L,K;
while (1){
scanf("%d%d",&L,&K);
if (L == 0 && K == 0)
break;
tree[K].push_back(L);
son[L]++;
}
int gen;
for (int i = 1; i <= N; i++){
if (son[i] == 0){
gen = i;
break;
}
}
tree_dp(gen);
printf("%d\n",max(dp[gen][0],dp[gen][1]));
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: