您的位置:首页 > 其它

D Floor problem(FZU 2104)

2017-11-25 20:28 302 查看
           D Floor problem

In this problem, we have f(n,x)=Floor[n/x]. Here Floor[x] is the biggest integer such that no larger than x. For example, Floor[1.1]=Floor[1.9]=1, Floor[2.0]=2.

You are given 3 positive integers n, L and R. Print the result of f(n,L)+f(n,L+1)+...+f(n,R), please.

Input

The first line of the input contains an integer T (T≤100), indicating the number of test cases.

Then T cases, for any case, only 3 integers n, L and R (1≤n, L, R≤10,000, L≤R).

Output
For each test case, print the result of f(n,L)+f(n,L+1)+...+f(n,R) in a single line.

Sample Input
3
1 2 3
100 2 100
100 3 100


Sample Output
0
382
332



由于C题还没看懂所以先放D题。。。。

题目的意思是:

第一行输入一个整数t,接下来有t组数据

接下来的t行,每行输入三个数n,l,r;令i=l ~ r

求(n/i)整数部分的和。


代码:

#include<stdio.h>
#include<algorithm>
using namespace std;
int main()
{
int t;
scanf("%d",&t);
while(t--)
{
int n,l,r,sum=0;
scanf("%d%d%d",&n,&l,&r);
for(int i=l;i<=r;i++)
sum+=n/i;
printf("%d\n",sum);
}
return 0;
}
就只有这么多了,没毛病!!

                                            
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: