您的位置:首页 > 其它

HihoCoder - 1631 Cats and Fish (2017ICPC北京站 模拟)

2017-11-25 18:36 411 查看


#1631 : Cats and Fish

时间限制:1000ms
单点时限:1000ms
内存限制:256MB


描述

There are many homeless cats in PKU campus. They are all happy because the students in the cat club of PKU take good care of them. Li lei is one of the members of the cat club. He loves those cats very much. Last
week, he won a scholarship and he wanted to share his pleasure with cats. So he bought some really tasty fish to feed them, and watched them eating with great pleasure. At the same time, he found an interesting question:
There are m fish and n cats, and it takes ci minutes for the ith cat
to eat out one fish. A cat starts to eat another fish (if it can get one) immediately after it has finished one fish. A cat never shares its fish with other cats. When there are not enough fish left, the cat which eats quicker has higher priority to get a
fish than the cat which eats slower. All cats start eating at the same time. Li Lei wanted to know, after x minutes, how many fish would be left.


输入

There are no more than 20 test cases.
For each test case:
The first line contains 3 integers: above mentioned m, n and x (0 < m <= 5000, 1 <= n <= 100, 0 <= x <= 1000).
The second line contains n integers c1,c2 …
cn,  ci means that it takes the ith
cat ci minutes to eat out a fish ( 1<= ci <= 2000).


输出

For each test case, print 2 integers p and q, meaning that there are p complete fish(whole fish) and q incomplete fish left after x minutes.

样例输入
2 1 1
1
8 3 5
1 3 4
4 5 1
5 4 3 2 1


样例输出
1 0
0 1
0 3


题意:给你一堆鱼,让一堆猫去吃,吃的速度不一样,求特定时间剩下多少鱼。

解题思路:模拟即可……慢慢模拟都不急……复杂度很低

#include<iostream>
#include<algorithm>
using namespace std;

int c[10000];
int mi[10000];
int vis[10000];

bool cmp(int a,int b)
{
return a>b;
}
int main(){

int m,n,x;
while(cin>>m>>n>>x){
for(int i=0;i<n;i++){
cin>>c[i];
mi[i]=0;
vis[i]=0;
}
sort(c,c+n);

for(int i=1;i<=x;i++)
for(int j=0;j<n;j++)
if(vis[j]==1){
mi[j]++;
if(mi[j]==c[j]){
vis[j]=0;
mi[j]=0;
}
}
else{
if(m>0){
m--;
mi[j]++;

vis[j]=1;
if(mi[j]==c[j]){
vis[j]=0;
mi[j]=0;
}
}
}

int in=0;
for(int i=0;i<n;i++)
if(vis[i]==1)
in+=vis[i];

if(m<0)
m=0;
cout<<m<<" "<<in<<endl;

}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: