您的位置:首页 > 其它

PAT - 甲级 - 1009. Product of Polynomials (25)(模拟)

2017-11-24 22:16 344 查看
This time, you are supposed to find A*B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 ... NK aNK, where
K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10, 0 <= NK < ... < N2 < N1 <=1000. 

Output Specification:

For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place. 
Sample Input
2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output
3 3 3.6 2 6.0 1 1.6


给定条件:

1.两个多项式的系数和指数

要求:

1.求出这两个多项式相乘后的结果

求解:

1.模拟即可,系数相称,指数相加。

#include <cstdio>
#include <algorithm>
using namespace std;

int n1, n2, a, cnt = 0;
double poly[1001], ans[2002], b;
int main() {
freopen("input.txt", "r", stdin);
fill(poly, poly+1001, 0);
fill(ans, ans+2002, 0);

scanf("%d", &n1);
for(int i = 0; i < n1; i++) {
scanf("%d%lf", &a, &b);
poly[a] = b;
}
scanf("%d", &n2);
for(int i = 0; i < n2; i++) {
scanf("%d%lf", &a, &b);
for(int j = 0; j < 1001; j++) {
ans[a+j] += b * poly[j];
}
}
for(int i = 0; i < 2002; i++) {
if(ans[i] != 0) {
cnt++;
}
}
printf("%d", cnt);
for(int i = 2001; i >= 0; i--) {
if(ans[i] != 0){
printf(" %d %.1f", i, ans[i]);
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: