您的位置:首页 > 其它

HDU 5543 Pick The Sticks【0-1背包】

2017-11-21 11:09 330 查看
The story happened long long ago. One day, Cao Cao made a special order called “Chicken Rib” to his army. No one got his point and all became very panic. However, Cao Cao himself felt very proud of his interesting idea and enjoyed it.

Xiu Yang, one of the cleverest counselors of Cao Cao, understood the command Rather than keep it to himself, he told the point to the whole army. Cao Cao got very angry at his cleverness and would like to punish Xiu Yang. But how can you punish someone because he’s clever? By looking at the chicken rib, he finally got a new idea to punish Xiu Yang.

He told Xiu Yang that as his reward of encrypting the special order, he could take as many gold sticks as possible from his desk. But he could only use one stick as the container.

Formally, we can treat the container stick as an LL length segment. And the gold sticks as segments too. There were many gold sticks with different length aiai and value vivi. Xiu Yang needed to put these gold segments onto the container segment. No gold segment was allowed to be overlapped. Luckily, Xiu Yang came up with a good idea. On the two sides of the container, he could make part of the gold sticks outside the container as long as the center of the gravity of each gold stick was still within the container. This could help him get more valuable gold sticks.

As a result, Xiu Yang took too many gold sticks which made Cao Cao much more angry. Cao Cao killed Xiu Yang before he made himself home. So no one knows how many gold sticks Xiu Yang made it in the container.

Can you help solve the mystery by finding out what’s the maximum value of the gold sticks Xiu Yang could have taken?

Input

The first line of the input gives the number of test cases, T(1≤T≤100)T(1≤T≤100). TT test cases follow. Each test case start with two integers, N(1≤N≤1000)N(1≤N≤1000) and L(1≤L≤2000)L(1≤L≤2000), represents the number of gold sticks and the length of the container stick. NN lines follow. Each line consist of two integers, ai(1≤ai≤2000)ai(1≤ai≤2000) and vi(1≤vi≤109)vi(1≤vi≤109), represents the length and the value of the ithith gold stick.

Output

For each test case, output one line containing Case #x: y, where xx is the test case number (starting from 1) and yy is the maximum value of the gold sticks Xiu Yang could have taken.

Sample Input

4

3 7

4 1

2 1

8 1

3 7

4 2

2 1

8 4

3 5

4 1

2 2

8 9

1 1

10 3

Sample Output

Case #1: 2

Case #2: 6

Case #3: 11

Case #4: 3

Hint

In the third case, assume the container is lay on x-axis from 0 to 5. Xiu Yang could put the second gold stick center at 0 and put the third gold stick center at 5,

so none of them will drop and he can get total 2+9=11 value.

In the fourth case, Xiu Yang could just put the only gold stick center on any position of [0,1], and he can get the value of 3.

题意:给你一个钢管,和许多许多价值不同的金条。金条可以首尾相接地插入钢管之中。金条可以露出一部分,但需要保证金条的重心还是在钢管之内的。

分析:不难想出这是一道类似于0-1背包的问题,但是问题出在,有几根状态不太正常的金条怎么办。 我们可以想象成最左端和最右端的金条可以花费减半。 那么我们还需要维护的状态就多了当前享受花费减半的金条数量。

两端的金条花费会出现浮点数的情况,但充其量是个.5,所以不妨预处理将所有长度扩二倍。得解!

dp[j][k]=max(dp[j][k],dp[j−a[i].len][k]+a[i].w);//不享受减免

dp[j][k]=max(dp[j][k],dp[j−a[i].len/2][k−1]+a[i].w);//享受

#include<iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>
using namespace std;
#define ll long long int
struct node {
ll len;
ll w;
}a[4005];
ll dp[4005][3];
int m;
ll L;
int main()
{
int n; int m; int cs = 0;
while (~scanf("%d", &n))
{
while (n--)
{
cs++;
ll Max = 0;
scanf("%d", &m);
scanf("%lld", &L);
memset(dp, 0, sizeof(dp));
L <<= 1;
ll tmp1, tmp2;
for (int i = 0; i < m; i++)
{
scanf("%lld%lld", &tmp1, &tmp2);
tmp1 <<= 1;
a[i].len = tmp1;
a[i].w = tmp2;
Max = max(Max, tmp2);
}
for (int i = 0; i < m; i++)
{
for (int j = L; j >= a[i].len / 2; j--)
{
for (int k = 0; k < 3; k++)
{
if (j >= a[i].len)
{
dp[j][k] = max(dp[j][k], dp[j - a[i].len][k] + a[i].w);
}
if (/*j >= a[i].len / 2&&*/k)
{
dp[j][k] = max(dp[j][k], dp[j - a[i].len / 2][k - 1] + a[i].w);
}
}
}
}
ll ans = max(max(Max, dp[L][0]), max(dp[L][1], dp[L][2]));
printf("Case #%d: %lld\n", cs, ans);
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: