您的位置:首页 > 其它

hdu 2391 Filthy Rich(DP)

2017-11-19 18:56 429 查看
Problem Description

They say that in Phrygia, the streets are paved with gold. You’re currently on vacation in Phrygia, and to your astonishment you discover that this is to be taken literally: small heaps of gold are distributed throughout the city. On a certain day, the Phrygians even allow all the tourists to collect as much gold as they can in a limited rectangular area. As it happens, this day is tomorrow, and you decide to become filthy rich on this day. All the other tourists decided the same however, so it’s going to get crowded. Thus, you only have one chance to cross the field. What is the best way to do so?

Given a rectangular map and amounts of gold on every field, determine the maximum amount of gold you can collect when starting in the upper left corner of the map and moving to the adjacent field in the east, south, or south-east in each step, until you end up in the lower right corner.

Input

The input starts with a line containing a single integer, the number of test cases. Each test case starts with a line, containing the two integers r and c, separated by a space (1 <= r, c <= 1000). This line is followed by r rows, each containing c many integers, separated by a space. These integers tell you how much gold is on each field. The amount of gold never negative. The maximum amount of gold will always fit in an int.

Output

For each test case, write a line containing “Scenario #i:”, where i is the number of the test case, followed by a line containing the maximum amount of gold you can collect in this test case. Finish each test case with an empty line.

Sample Input

1

3 4

1 10 8 8

0 0 1 8

0 27 0 4

Sample Output

Scenario #1:

42

dp题 , 当前状态由上个状态推导过来

由于 只能向东 东南 和南 三个方向走 ,

那么我们当前状态 dp[i][j] 由 dp[i-1][j], (dp[i][j-1], dp[i-1][j-1]) 这三个的 最大值 加上 dp[i][j]本身的值决定 状态转移方程为 :

dp[i][j]=max(dp[i-1][j],max(dp[i][j-1],dp[i-1][j-1]))+Map[i][j];

code:

#include <iostream>
#include <bits/stdc++.h>
using namespace std;
int main ()
{
int N;
scanf("%d",&N);
int dp[1003][1003];
int Map[1003][1003];
for (int k=1; k<=N; k++)
{
memset(dp, 0, sizeof(dp));
memset(Map, 0, sizeof(Map));
printf ("Scenario #%d:\n",k);
int m, n;
scanf("%d%d",&m,&n);
for (int i=1; i<=m; i++)
{
for (int j=1; j<=n; j++)
{
scanf("%d",&Map[i][j]);
}
}
for (int i=1; i<=m; i++)
{
for (int j=1; j<=n; j++)
{
dp[i][j]=max(dp[i-1][j],max(dp[i][j-1],dp[i-1][j-1]))+Map[i][j];
}
}
printf ("%d\n\n",dp[m]
);

}

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: