您的位置:首页 > 其它

杭电oj1005

2017-11-19 15:18 369 查看


1005 - Number Sequence

时间限制:Java: 2000 ms / Others: 1000 ms
内存限制:Java: 65536 KB / Others: 32768 KB


问题描述

A number sequence is defined as follows:f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.Given A, B, and n, you are to calculate the value of f(n).


输入说明

The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.


输出说明

For each test case, print the value of f(n) on a single line.


输入样例

1 1 3 1 2 10 0 0 0



输出样例

2 5

这道题之前用递归做的,还觉得哇,好简单啊,结果runtimeError了,然后测试了一下,不要说1000了,即使用100之类很小的数来递归,也会非常慢,而且据说会超出堆栈.后来才知道,原来是个循环节的概念,因为有mod 7,所以f(n)取值是0-6,7个取值,而f(n)又由上头两个决定,因此有7*7=49种答案,因此在50以内必然出现循环,所以我们用数组模拟前49组数组,后面的数据只要mod (模除)循环节就可以了,对应的的数组里头取值,下面附上代码

------------------------------------下面附上AC代码-----------------------

#include <iostream>
using namespace std;
int main()
{
int A,B;
int N;
int f[50];
while(cin>>A>>B>>N)
{
if(A==0&&B==0&&N==0)break;
int n=3;
f[1]=f[2]=1;
for(n=3;n!=50;++n)
{
f[n]=(A*f[n-1]+B*f[n-2])%7;
if(f[n]==1&&f[n-1]==1)break;
}
N=N%(n-2);
if(N==0)cout<<f[(n-2)]<<endl;
else cout<<f[N]<<endl;
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: