您的位置:首页 > 其它

HDU 2391 Filthy Rich(动态规划)

2017-11-19 13:31 387 查看
Problem Description

They say that in Phrygia, the streets are paved with gold. You’re currently on vacation in Phrygia, and to your astonishment you discover that this is to be taken literally: small heaps of gold are distributed throughout the city. On a certain day, the Phrygians
even allow all the tourists to collect as much gold as they can in a limited rectangular area. As it happens, this day is tomorrow, and you decide to become filthy rich on this day. All the other tourists decided the same however, so it’s going to get crowded.
Thus, you only have one chance to cross the field. What is the best way to do so?

Given a rectangular map and amounts of gold on every field, determine the maximum amount of gold you can collect when starting in the upper left corner of the map and moving to the adjacent field in the east, south, or south-east in each step, until you end
up in the lower right corner.

 

Input

The input starts with a line containing a single integer, the number of test cases. Each test case starts with a line, containing the two integers r and c, separated by a space (1 <= r, c <= 1000). This line is followed by r rows, each containing c many integers,
separated by a space. These integers tell you how much gold is on each field. The amount of gold never negative. The maximum amount of gold will always fit in an int.

 

Output

For each test case, write a line containing “Scenario #i:”, where i is the number of the test case, followed by a line containing the maximum amount of gold you can collect in this test case. Finish each test case with an empty line.

 

Sample Input

1
3 4
1 10 8 8
0 0 1 8
0 27 0 4

 

Sample Output

Scenario #1:
42

 

开始用  深搜写的 超时无奈后来改成 动态规划。。

code:

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
const int maxn=1010;
int n,m,a[maxn][maxn],dp[maxn];
bool vis[maxn][maxn];
int ans;
int main()
{
int t;
scanf("%d",&t);
for(int k=1;k<=t;k++){
scanf("%d %d",&n,&m);
memset(a,0,sizeof(a));
for(int i=1;i<=n;i++)
for(int j=1;j<=m;j++)
scanf("%d",&a[i][j]);
// memset(dp,0,sizeof(dp));
for(int i=1;i<=n;i++)
for(int j=1;j<=m;j++)
{
a[i][j]+=max(max(a[i-1][j],a[i][j-1]),a[i-1][j-1]);
}
printf("Scenario #%d:\n",k);
printf("%d\n",a
[m]);
printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: