您的位置:首页 > 其它

【poj 2352】 Stars 【Ural Collegiate Programming Contest 1999】

2017-11-17 23:04 441 查看
Description
Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not
higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars.



For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level
0, two stars of the level 1, one star of the level 2, and one star of the level 3.

You are to write a program that will count the amounts of the stars of each level on a given map.
Input
The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000).
There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate.

Output
The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains
amount of stars of the level N-1.
Sample Input
5
1 1
5 1
7 1
3 3
5 5

Sample Output
1
2
1
1
0

这道题可以用线段树或者树状数组解决,由于输入为有序,所以只要每次读入后求比当前星星x坐标小的有多少个就可以了,下面是程序:#include<stdio.h>
#include<iostream>
using namespace std;
const int N=32005;
int c
,ans
;
int lowbit(int x){
return x&(-x);
}
int sum(int x){
int s=0;
while(x>0){
s+=c[x];
x-=lowbit(x);
}
return s;
}
void add(int x,int w){
while(x<=N){
c[x]+=w;
x+=lowbit(x);
}
}
int main(){
int n,x,y,i;
scanf("%d",&n);
for(i=0;i<n;i++){
scanf("%d%d",&x,&y);
ans[sum(x+1)]++;
add(x+1,1);
}
for(i=0;i<n;i++){
printf("%d\n",ans[i]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: