您的位置:首页 > 其它

hdu 1238 Substrings

2017-11-17 11:04 211 查看
点击打开链接


Substrings

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 11034    Accepted Submission(s): 5310


Problem Description

You are given a number of case-sensitive strings of alphabetic characters, find the largest string X, such that either X, or its inverse can be found as a substring of any of the given strings.

 

Input

The first line of the input file contains a single integer t (1 <= t <= 10), the number of test cases, followed by the input data for each test case. The first line of each test case contains a single integer n (1 <= n <= 100), the number of given strings,
followed by n lines, each representing one string of minimum length 1 and maximum length 100. There is no extra white space before and after a string. 

 

Output

There should be one line per test case containing the length of the largest string found.

 

Sample Input

2
3
ABCD
BCDFF
BRCD
2
rose
orchid

 

Sample Output

2
2

找到最短的串,暴力所有字串,去匹配。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<algorithm>
using namespace std;
int main()
{
int ca,n,f;
scanf("%d",&ca);
string s[105];
while(ca--)
{
int mma=1000;
int ma=0;
scanf("%d",&n);
for(int i=0;i<n;i++)
{
cin>>s[i];
if(s[i].size()<mma)
{
mma=s[i].size();
f=i;
}
}
int le=s[f].size();
for(int i=0;i<le;i++)
{
for(int j=0;j<le;j++)
{
string s1,s2;
s1=s[f].substr(i,j);
s2=s1;
reverse(s2.begin(),s2.end());
int flag=1;
for(int k=0;k<n;k++)
{
if(s[k].find(s1,0)==-1&&s[k].find(s2,0)==-1)
{
flag=0;
break;
}
}
if(flag&&s1.size()>ma)
ma=s1.size();
}
}
cout<<ma<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: