您的位置:首页 > 其它

【LightOJ - 1116】Ekka Dokka 【算数基本定理】

2017-11-17 08:34 405 查看
Ekka and his friend Dokka decided to buy a cake. They both love cakes and that’s why they want to share the cake after buying it. As the name suggested that Ekka is very fond of odd numbers and Dokka is very fond of even numbers, they want to divide the cake such that Ekka gets a share of N square centimeters and Dokka gets a share of M square centimeters where N is odd and M is even. Both N and M are positive integers.

They want to divide the cake such that N * M = W, where W is the dashing factor set by them. Now you know their dashing factor, you have to find whether they can buy the desired cake or not.

Input
4000

Input starts with an integer T (≤ 10000), denoting the number of test cases.

Each case contains an integer W (2 ≤ W < 263). And W will not be a power of 2.

Output

For each case, print the case number first. After that print “Impossible” if they can’t buy their desired cake. If they can buy such a cake, you have to print N and M. If there are multiple solutions, then print the result where M is as small as possible.

Sample Input

3

10

5

12

Sample Output

Case 1: 5 2

Case 2: Impossible

Case 3: 3 4

题意: 给一个数字,问满足 n * m = w ,其中n为偶数,m为奇数。

现在求最小的满足式子的n。

分析: 我们可以从算数基本定理来考虑,对于一个数字,如果其是偶数的话,其质因子分解是什么样子? 那么其质因子2的指数一定是>=1,所以我们现在想求最小的偶数 * 奇数, 其实就是求最大奇数,最大的奇数不就是将所有的质因子2都去掉不就是完全奇数了。

所以就很明确了。

代码

#include<bits/stdc++.h>
using namespace std;
typedef pair<int,int>pii;
#define first fi
#define second se
#define  LL long long
#define fread() freopen("in.txt","r",stdin)
#define fwrite() freopen("out.txt","w",stdout)
#define CLOSE() ios_base::sync_with_stdio(false)

const int MAXN = 1e5;
const int MAXM = 1e6;
const int mod = 1e9+7;
const int inf = 0x3f3f3f3f;

int main(){
CLOSE();
//  fread();
//  fwrite();
int T ;scanf("%d",&T);int ncase=1;
while(T--){
printf("Case %d: ",ncase++);
LL  w,m;scanf("%lld",&w);
if(w&1){
puts("Impossible");
continue;
}
int cnt=0; m=1;
while(w){
if(w&1) break;
cnt++;
w>>=1;
}
//printf("cnt==%d\n",cnt);
printf("%lld %lld\n",w,(m<<cnt));
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: