您的位置:首页 > 其它

2669 2-2 Time类的定义

2017-11-16 18:51 225 查看
2-2 Time类的定义

Time Limit: 1000MS Memory Limit: 65536KB

Problem Description

通过本题目的练习可以掌握类与对象的定义;
设计一个时间类Time,私有数据成员有hour(时)、minute(分)、second(秒);
公有成员函数有:setHour(int)设置数据成员hour的值(采用12小时制),非法的输入默认为12;setMinue(int)设置数据成员minute的值,非法输入默认为0;setSecond(int)设置数据成员second的值,非法输入默认为0;setTime(int,int,int)设置时、分、秒三个数据成员的值;
showTime()显示时间对象的值。
在主函数main()中调用相应成员函数,使得时间对象的值能从键盘接收,并正确显示。

提示:时、分、秒均按2位数值形式显示 。

Input

输入3个整数,用一个空格间隔

Output

输出 时、分、秒的值,中间用“:”间隔

Example Input

10 11 12


Example Output

10:11:12


Hint

输入
58 23 85
输出
12:23:00

#include <bits/stdc++.h>
using namespace std;

class Clock
{
private:
int h,m,s;
public:
void input(int x, int y, int z)
{
if(x<0 || x>10){h = 12;}
else {h = x;}
if(y >=60 || y<0){m = 0;}
else {m = y;}
if(z >=60 || z<0){s = 0;}
else {s = z;}
}
void output()
{
printf("%02d:%02d:%02d\n",h,m,s);
}
};

int main()
{
Clock dcup;
int x,y,z;
cin >> x >> y >> z;
dcup.input(x, y, z);
dcup.output();
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: