您的位置:首页 > 其它

HDU 1035 Robot Motion

2017-11-15 20:28 302 查看


Problem Description


 

A robot has been programmed to follow the instructions in its path. Instructions for the next direction the robot is to move are laid down in a grid. The possible instructions are
N north (up the page) 

S south (down the page) 

E east (to the right on the page) 

W west (to the left on the page)
For example, suppose the robot starts on the north (top) side of Grid 1 and starts south (down). The path the robot follows is shown. The robot goes through 10 instructions in the grid before
leaving the grid.
Compare what happens in Grid 2: the robot goes through 3 instructions only once, and then starts a loop through 8 instructions, and never exits.
You are to write a program that determines how long it takes a robot to get out of the grid or how the robot loops around.


Input

There will be one or more grids for robots to navigate. The data for each is in the following form. On the first line are three integers separated by blanks: the number of rows in the grid,
the number of columns in the grid, and the number of the column in which the robot enters from the north. The possible entry columns are numbered starting with one at the left. Then come the rows of the direction instructions. Each grid will have at least
one and at most 10 rows and columns of instructions. The lines of instructions contain only the characters N, S, E, or W with no blanks. The end of input is indicated by a row containing 0 0 0.


Output

For each grid in the input there is one line of output. Either the robot follows a certain number of instructions and exits the grid on any one th
4000
e four sides or else the robot follows the
instructions on a certain number of locations once, and then the instructions on some number of locations repeatedly. The sample input below corresponds to the two grids above and illustrates the two forms of output. The word “step” is always immediately followed
by “(s)” whether or not the number before it is 1.


Sample Input

3 6 5 

NEESWE 

WWWESS 

SNWWWW 

4 5 1 

SESWE 

EESNW 

NWEEN 

EWSEN 

0 0


Sample Output

10 step(s) to exit 

3 step(s) before a loop of 8 step(s)


题目大意:

输入x,y,表示一个x*y的字符矩阵,输入c表示从第一行的第c个字符开始执行,N表示向上,S表示向下,E表示向右,W表示向左。如果最终走出矩阵则输出 s step(s) to exit,s表示走出矩阵所用步数,如果进入循环则输出s-w step(s) before a loop of w step(s),s-w为进入循环前走的步数,w表示循环内部的步数。


C++

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
char m[15][15];
int n[15][15];
int x,y,s,w;
int jq(int a)
{
int b,c,d,e,f;
b=1;n[b][a]=1;
while(1)
{
if(m[b][a]=='N')
{
b--;s++;
if(n[b][a]!=0)
{
w=n[b+1][a]-n[b][a]+1;
return w;
}
n[b][a]=n[b+1][a]+1;
}
else if(m[b][a]=='S')
{
b++;s++;
if(n[b][a]!=0)
{
w=n[b-1][a]-n[b][a]+1;
return w;
}
n[b][a]=n[b-1][a]+1;
}
else if(m[b][a]=='W')
{
a--;s++;
if(n[b][a]!=0)
{
w=n[b][a+1]-n[b][a]+1;
return w;
}
n[b][a]=n[b][a+1]+1;
}
else if(m[b][a]=='E')
{
a++;s++;
if(n[b][a]!=0)
{
w=n[b][a-1]-n[b][a]+1;
return w;
}
n[b][a]=n[b][a-1]+1;
}
if(b>x||b<=0||a>y||a<=0)
return w;
}
}
int main()
{
int a,b,c,d,e,f;
while(cin>>x>>y)
{
if(x==0&&y==0)
break;
cin>>c;
memset(n,0,sizeof(n));
s=0;w=0;
for(a=1;a<=x;a++)
{
for(b=1;b<=y;b++)
cin>>m[a][b];
}
f=jq(c);
if(f==0)
printf("%d step(s) to exit\n",s);
else
printf("%d step(s) before a loop of %d step(s)\n",s-w,w);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: