您的位置:首页 > 其它

PAT - 甲级 - 1084. Broken Keyboard (20)(Hash散列)

2017-11-15 17:20 429 查看
On a broken keyboard, some of the keys are worn out. So when you type some sentences, the characters corresponding to those keys will not appear on screen.

Now given a string that you are supposed to type, and the string that you actually type out, please list those keys which are for sure worn out.

Input Specification:

Each input file contains one test case. For each case, the 1st line contains the original string, and the 2nd line contains the typed-out string. Each string contains no more than 80 characters which are either English letters [A-Z] (case insensitive), digital
numbers [0-9], or "_" (representing the space). It is guaranteed that both strings are non-empty.

Output Specification:

For each test case, print in one line the keys that are worn out, in the order of being detected. The English letters must be capitalized. Each worn out key must be printed once only. It is guaranteed that there is at least one worn out key.
Sample Input:
7_This_is_a_test
_hs_s_a_es

Sample Output:
7TI


给定条件:

1.两个字符串

2.第一个字符串是想要通过键盘打出的字符串

3.第二个字符串是实际通过键盘打出的字符串

要求:

1.求出键盘上的那些按键是坏了

2.输出要求
2.1.输出顺序是被发现的顺序
2.2.输出的英文字母要求是大写
2.3.输出的字符不出现重复

求解:

1.对能打出的字符进行标记,则期望打出的字符串中,没有被标记的就是坏了的键盘

2.对已判定为坏了的并且已输出的键进行标记,防止重复输出

#include<iostream>
#include<cstdio>
#include<string>
using namespace std;

string s1, s2;
bool isBroken[1000];
bool isPrinted[1000];

int main(){
fill(isBroken, isBroken+1000, false);
fill(isPrinted, isPrinted+1000, false);
cin>>s1>>s2;
for(int i = 0; i < s2.length(); i++) {
if(s2[i] >= 'a' && s2[i] <= 'z') {
isBroken[s2[i]] = isBroken[s2[i]-'a'+'A'] = true;
} else if(s2[i] >= 'A' && s2[i] <= 'Z') {
isBroken[s2[i]] = isBroken[s2[i]-'A'+'a'] = true;
} else {
isBroken[s2[i]] = true;
}
}

for(int i = 0; i < s1.length(); i++) {
if(isBroken[s1[i]] == false && isPrinted[s1[i]] == false) {
if(s1[i] >= 'a' && s1[i] <= 'z'){
isPrinted[s1[i]] = isPrinted[s1[i]-'a'+'A'] = true;
printf("%c", s1[i]-'a'+'A');
} else if(s1[i] >= 'A' && s1[i] <= 'Z') {
isPrinted[s1[i]] = isPrinted[s1[i]-'A'+'a'] = true;
printf("%c", s1[i]);
} else {
isPrinted[s1[i]] = true;
printf("%c", s1[i]);
}

}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: