您的位置:首页 > 编程语言 > C语言/C++

PAT甲级 1053. Path of Equal Weight (30)

2017-11-15 10:50 375 查看
题目:

Given a non-empty tree with root R, and with weight Wi assigned to each tree node Ti. The weight of a path from R to Lis defined to be the sum of the weights of all the nodes
along the path from R to any leaf node L.

Now given any weighted tree, you are supposed to find all the paths with their weights equal to a given number. For example, let's consider the tree showed in Figure 1: for each node, the upper number is the node ID which is a two-digit number, and the lower
number is the weight of that node. Suppose that the given number is 24, then there exists 4 different paths which have the same given weight: {10 5 2 7}, {10 4 10}, {10 3 3 6 2} and {10 3 3 6 2}, which correspond to the red edges in Figure 1.



Figure 1

Input Specification:

Each input file contains one test case. Each case starts with a line containing 0 < N <= 100, the number of nodes in a tree, M (< N), the number of non-leaf nodes, and 0 < S < 230, the given weight number. The next line contains
N positive numbers where Wi (<1000) corresponds to the tree node Ti. Then M lines follow, each in the format:
ID K ID[1] ID[2] ... ID[K]


where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 00.

Output Specification:

For each test case, print all the paths with weight S in non-increasing order. Each path occupies a line with printed weights from the root to the leaf in order. All the numbers must be separated by a space with no extra space at the end of
the line.

Note: sequence {A1, A2, ..., An} is said to be greater than sequence {B1, B2,
..., Bm} if there exists 1 <= k < min{n, m} such that Ai = Bifor i=1, ... k, and Ak+1 > Bk+1.
Sample Input:
20 9 24
10 2 4 3 5 10 2 18 9 7 2 2 1 3 12 1 8 6 2 2
00 4 01 02 03 04
02 1 05
04 2 06 07
03 3 11 12 13
06 1 09
07 2 08 10
16 1 15
13 3 14 16 17
17 2 18 19

Sample Output:
10 5 2 7
10 4 10
10 3 3 6 2
10 3 3 6 2

思路:
这里主要是根据深度优先搜索找出符合的路径,再进行排序。也可以再查找时,先把子节点根据权值的大小进行排序,这样得出的路径就无需再排序一次了。下面代码采用后一种做法。

代码:

#include<iostream>
#include<vector>
#include<algorithm>
using namespace std;

int S;

struct node
{
int weight;
vector<int> child;
};

vector<node> tree(100);

bool cmp(int n1, int n2)
{
return tree[n1].weight > tree[n2].weight;
}

vector<vector<int>> all_road;
void findroad(int id, vector<int> r, int w)
{
w += tree[id].weight;
r.push_back(tree[id].weight);
if (tree[id].child.size() != 0)
{
int i;
for (i = 0; i < tree[id].child.size(); ++i)
{
findroad(tree[id].child[i],r,w);
}
}
else
{
//为叶节点
if (w == S)
{
all_road.push_back(r);
}
else
return;
}
}

int main()
{
//ifstream cin;
//cin.open("case1.txt");

//input
int N, M;
cin >> N >> M >> S;

tree.resize(N);
int i, j;
for (i = 0; i < N; ++i)
{
cin >> tree[i].weight;
}
int id, num;
for (i = 0; i < M; ++i)
{
cin >> id >> num;
tree[id].child.resize(num);
for (j = 0; j < num; ++j)
{
cin >> tree[id].child[j];
}
//将子节点先根据weight大小排序
sort(tree[id].child.begin(),tree[id].child.end(),cmp);
}

vector<int> rr;
findroad(0,rr,0);

if (all_road.size() != 0)
{
for (i = 0; i < all_road.size(); ++i)
{
for (j = 0; j < all_road[i].size(); ++j)
{
cout << all_road[i][j];
if (j != all_road[i].size() - 1)
{
cout << " ";
}
else
cout << endl;
}
}
}

system("pause");
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  PAT c++ 深度优先搜索