您的位置:首页 > 编程语言 > C语言/C++

PAT甲级 1052. Linked List Sorting (25)

2017-11-15 10:18 260 查看
题目:

A linked list consists of a series of structures, which are not necessarily adjacent in memory. We assume that each structure contains an integer key and a Next pointer to the next structure. Now given a linked list, you are supposed to sort the structures
according to their key values in increasing order.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive N (< 105) and an address of the head node, where N is the total number of nodes in memory and the address of a node is a 5-digit positive
integer. NULL is represented by -1.

Then N lines follow, each describes a node in the format:

Address Key Next

where Address is the address of the node in memory, Key is an integer in [-105, 105], and Next is the address of the next node. It is guaranteed that all the keys are distinct and there is no
cycle in the linked list starting from the head node.

Output Specification:

For each test case, the output format is the same as that of the input, where N is the total number of nodes in the list and all the nodes must be sorted order.
Sample Input:
5 00001
11111 100 -1
00001 0 22222
33333 100000 11111
12345 -1 33333
22222 1000 12345

Sample Output:
5 12345
12345 -1 00001
00001 0 11111
11111 100 22222
22222 1000 33333
33333 100000 -1

思路:
先筛选节点,查找有效链表。再根据key值排序,输出。要注意空链表,以及查找时避免使用vector的find()函数和向量的插入删除,否则会有测试点运行超时。

代码:

#include<iostream>
#include<vector>
#include<algorithm>
using namespace std;
//先查找有效链表
//再根据关键字排序
struct node
{
int key;
int next;
};
int N;
vector<node> Node(100000);//一定要写,否则无法排序,会有指针越界
//排序函数
bool cmp(const int &n1, const int &n2)
{
return Node[n1].key < Node[n2].key;
}

int main()
{
ifstream cin;
cin.open("case1.txt");

int head;
cin >> N>>head;
int i,address;
for (i = 0; i < N; ++i)
{
cin >> address;
//scanf("%d%d%d",&Node[i].address,&Node[i].key ,&Node[i].next);
cin >> Node[address].key >> Node[address].next;
}

//筛选链表
vector<int> add; //有效节点的地址

int phead= head;
while (head!=-1)
{
add.push_back(head);
head = Node[head].next;
}

//排序
sort(add.begin(),add.end(),cmp);

//输出
cout << add.size();
if (add.size() != 0)
{
printf(" %05d\n",add[0]);
for (i = 0; i < add.size(); ++i)
{
printf("%05d %d ",add[i],Node[add[i]].key);
if (i != add.size() - 1)
{
printf("%05d\n",add[i+1]);
}
else
{
printf("-1\n");
}
}
}
else
{
//链表为空的情况
cout << " -1"<<endl;
}

system("pause");
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  PAT c++ 链表