您的位置:首页 > 大数据 > 人工智能

HDOJ-1702 ACboy needs your help again!

2017-11-14 22:29 363 查看


ACboy needs your help again!

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 8993    Accepted Submission(s): 4489


Problem Description

ACboy was kidnapped!! 

he miss his mother very much and is very scare now.You can't image how dark the room he was put into is, so poor :(.

As a smart ACMer, you want to get ACboy out of the monster's labyrinth.But when you arrive at the gate of the maze, the monste say :" I have heard that you are very clever, but if can't solve my problems, you will die with ACboy."

The problems of the monster is shown on the wall:

Each problem's first line is a integer N(the number of commands), and a word "FIFO" or "FILO".(you are very happy because you know "FIFO" stands for "First In First Out", and "FILO" means "First In Last Out").

and the following N lines, each line is "IN M" or "OUT", (M represent a integer).

and the answer of a problem is a passowrd of a door, so if you want to rescue ACboy, answer the problem carefully!

 

Input

The input contains multiple test cases.

The first line has one integer,represent the number oftest cases.

And the input of each subproblem are described above.

 

Output

For each command "OUT", you should output a integer depend on the word is "FIFO" or "FILO", or a word "None" if you don't have any integer.

 

Sample Input

4
4 FIFO
IN 1
IN 2
OUT
OUT
4 FILO
IN 1
IN 2
OUT
OUT
5 FIFO
IN 1
IN 2
OUT
OUT
OUT
5 FILO
IN 1
IN 2
OUT
IN 3
OUT

 

Sample Output

1
2
2
1
1
2
None
2
3

 

题目链接

栈和队列的基本应用

 



队列

头文件

stack 

queue

定义

stack<int> s1;

Queue<int>q1;

判断是否空

S1.empty()

Q1.empty()

求元素个数

S1.size()

Q1.size();

删除首元素

S1.pop()

Q1.pop()

获得首元素值

S1.top();

Q1.front()

加入新元素

S1.push()

Q1.push()

返回尾元素值



Q1.back();

#include<iostream>
#include<string>
#include<stack>
#include<queue>
using namespace std;
int main()
{
int i,j,m,n;
string s;
int ss;
cin>>n;
while(n--)
{
cin>>m>>s;
if(s[2]=='F')
{
queue<int>q;
while(m--)
{
cin>>s;
if(s[0]=='I')
{
cin>>ss;
q.push(ss);
}
else if(s[0]=='O')
{
if(!q.empty())
{
cout<<q.front()<<endl;
q.pop();
}
else
cout<<"None"<<endl;
}
}
}
else if(s[2]=='L')
{
stack<int>k;
while(m--)
{
cin>>s;
if(s[0]=='I')
{
cin>>ss;
k.push(ss);
}
else if(s[0]=='O')
{
if(!k.empty())
{
cout<<k.top()<<endl;
k.pop();
}
else
cout<<"None"<<endl;
}
}
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: