您的位置:首页 > 其它

POJ3522 SlimSpan 最大边和最小边的差最小的生成树

2017-11-14 21:07 387 查看
Slim Span

Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 7870 Accepted: 4191
Description

Given an undirected weighted graph G, you should find one of spanning trees specified as follows.

The graph G is an ordered pair (V, E), where V is a set of vertices {v1, v2, …, vn} and E is a set of undirected edges {e1, e2,
…, em}. Each edge e ∈ E has its weight w(e).

A spanning tree T is a tree (a connected subgraph without cycles) which connects all the n vertices with n − 1 edges. The slimness of a spanning tree T is defined as the difference between the largest weight and the smallest weight
among the n − 1 edges of T.



Figure 5: A graph G and the weights of the edges
For example, a graph G in Figure 5(a) has four vertices {v1, v2, v3, v4} and five undirected edges {e1, e2, e3, e4, e5}.
The weights of the edges are w(e1) = 3, w(e2) = 5, w(e3) = 6, w(e4) = 6, w(e5) = 7 as shown in Figure 5(b).



Figure 6: Examples of the spanning trees of G
There are several spanning trees for G. Four of them are depicted in Figure 6(a)~(d). The spanning tree Ta in Figure 6(a) has three edges whose weights are 3, 6 and 7. The largest weight is 7 and the smallest weight is 3 so that
the slimness of the tree Ta is 4. The slimnesses of spanning trees Tb, Tc and Td shown in Figure 6(b), (c) and (d) are 3, 2 and 1, respectively. You can easily see the slimness
of any other spanning tree is greater than or equal to 1, thus the spanning tree Td in Figure 6(d) is one of the slimmest spanning trees whose slimness is 1.

Your job is to write a program that computes the smallest slimness.

Input

The input consists of multiple datasets, followed by a line containing two zeros separated by a space. Each dataset has the following format.

nm 
a1b1w1
  
ambm<
ada4
/em>
wm
Every input item in a dataset is a non-negative integer. Items in a line are separated by a space. n is the number of the vertices and m the number of the edges. You can assume 2 ≤ n ≤ 100 and 0 ≤ m≤ n(n − 1)/2. ak and bk (k =
1, …, m) are positive integers less than or equal to n, which represent the two vertices vak and vbk connected by the kth edge ek. wk is
a positive integer less than or equal to 10000, which indicates the weight of ek. You can assume that the graph G = (V, E) is simple, that is, there are no self-loops (that connect the same vertex) nor parallel
edges (that are two or more edges whose both ends are the same two vertices).

Output

For each dataset, if the graph has spanning trees, the smallest slimness among them should be printed. Otherwise, −1 should be printed. An output should not contain extra characters.

Sample Input
4 5
1 2 3
1 3 5
1 4 6
2 4 6
3 4 7
4 6
1 2 10
1 3 100
1 4 90
2 3 20
2 4 80
3 4 40
2 1
1 2 1
3 0
3 1
1 2 1
3 3
1 2 2
2 3 5
1 3 6
5 10
1 2 110
1 3 120
1 4 130
1 5 120
2 3 110
2 4 120
2 5 130
3 4 120
3 5 110
4 5 120
5 10
1 2 9384
1 3 887
1 4 2778
1 5 6916
2 3 7794
2 4 8336
2 5 5387
3 4 493
3 5 6650
4 5 1422
5 8
1 2 1
2 3 100
3 4 100
4 5 100
1 5 50
2 5 50
3 5 50
4 1 150
0 0

Sample Output
1
20
0
-1
-1
1
0
1686
50

【题意】
求最大边与最小边差值最小的生成树。
对边权排序,依次枚举最小边,再与后边组成生成树,直到满足题意。若不连通,输出-1,反之,输出差值
最小生成树有一个很重要的性质:在构造生成树时有可能选择不同的边,但最小生成树的权是唯一的!所以在用kruskal算法时第一次加入的必然是最小生成树的最小边权值,最小边确定后,最小生成树的最大边的权值是所以生成树中最小的,于是只要枚举最小边,然后求最小生成树,就可以得到最大边,只要每次更新最优解就行了
 
#include <iostream>
#include <stdio.h>
#include <cstring>
#include <algorithm>
#include <math.h>
#include <stack>
#include <queue>
#include <vector>
using namespace std;

const int maxn = 50000+5;
const int INF = 0x3f3f3f3f;

int n, m;
struct Edge{
int u, v, w;
}e[maxn];

int cmp(const void *a, const void *b)
{
Edge *c = (Edge *)a;
Edge *d = (Edge *)b;
return c->w-d->w;
}

int p[102];
int find(int x)
{
if(p[x] != x) p[x] = find(p[x]);
return p[x];
}

int kruskal(int t)
{
int i, cnt = 0;
for(i = 1; i <= n; i++) p[i] = i;
for(i = t; i < m; i++) {
if(find(e[i].u) == find(e[i].v)) continue;
p[find(e[i].v)] = find(e[i].u);
if(++cnt == n-1) break;
}
if(cnt < n-1) return -1;
return e[i].w-e[t].w;
}
int main()
{
//freopen("in.txt", "r", stdin);
while(scanf("%d%d", &n, &m), m|n)
{
for(int i = 0; i< m; i++) scanf("%d%d%d", &e[i].u, &e[i].v, &e[i].w);
qsort(e, m, sizeof(Edge), cmp);
int tmp, ans = INF;
for(int i = 0; i <= m-n+1; i++) {
tmp = kruskal(i);
if(tmp == -1) break;
if(tmp<ans) ans = tmp;
}
if(ans == INF) printf("-1\n");
else printf("%d\n", ans);
}
return 0;
}







                                            
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: