您的位置:首页 > 其它

1002. A+B for Polynomials (25)

2017-11-14 18:49 411 查看
A+B for Polynomials (25)

This time, you are supposed to find A+B where A and B are two polynomials.

Input

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 … NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, …, K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10,0 <= NK < … < N2 < N1 <=1000.

Output

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input

2 1 2.4 0 3.2

2 2 1.5 1 0.5

Sample Output

3 2 1.5 1 2.9 0 3.2

#include <bits/stdc++.h>
using namespace std;
int main()
{
int k1, k2;
double a[1234];
int ma[1234];
int sum = 0;
memset(ma, 0, sizeof(ma));
memset(a, 0, sizeof(a));
cin>>k1;
while(k1--)
{
int i;
double w;
cin>>i;
cin>>w;
if(a[i]==0)
{
a[i] += w;
ma[i] = 1;
sum++;
}
else if(w!=0)
{
a[i]+=w;
if(a[i]==0)
{
ma[i] = 0;
sum--;
}
}
}
cin>>k2;
while(k2--)
{
int i;
double w;
cin>>i;
cin>>w;
if(a[i]==0)
{
a[i] += w;
ma[i] = 1;
sum++;
}
else if(w!=0)
{
a[i]+=w;
if(a[i]==0)
{
ma[i] = 0;
sum--;
}
}
}
cout<<sum;
for(int i=1000; i>=0; i--)
{
if(a[i])
printf(" %d %.1lf", i, a[i]);
}
printf("\n");
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: