您的位置:首页 > 其它

UVa 10474Where is the Marble STL 模板练习

2017-11-14 13:24 330 查看
从今天开始就正式开始练习刘汝佳的算法竞赛入门了,也开始试着用Vjudge,确实很方便,各大平台都可以用,否则按照访问UVa那么慢的状态,真是没耐心等。。。

Raju and Meena love to play with Marbles. They have got a lot of

marbles with numbers written on them. At the beginning, Raju would

place the marbles one after another in ascending order of the numbers

written on them. Then Meena would ask Raju to find the first marble

with a certain number. She would count 1…2…3. Raju gets one point

for correct answer, and Meena gets the point if Raju fails. After some

fixed number of trials the game ends and the player with maximum

points wins. Today it’s your chance to play as Raju. Being the smart

kid, you’d be taking the favor of a computer. But don’t underestimate

Meena, she had written a program to keep track how much time you’re

taking to give all the answers. So now you have to write a program,

which will help you in your role as Raju.

Input

There can be multiple test cases. Total no of test cases is less than 65. Each test case consists begins

with 2 integers: N the number of marbles and Q the number of queries Mina would make. The next

N lines would contain the numbers written on the N marbles. These marble numbers will not come

in any particular order. Following Q lines will have Q queries. Be assured, none of the input numbers

are greater than 10000 and none of them are negative.

Input is terminated by a test case where N = 0 and Q = 0.

Output

For each test case output the serial number of the case.

For each of the queries, print one line of output. The format of this line will depend upon whether

or not the query number is written upon any of the marbles. The two different formats are described

below:

• ‘x found at y’, if the first marble with number x was found at position y. Positions are numbered

1, 2, … , N.

• ‘x not found’, if the marble with number x is not present.

Look at the output for sample input for details.

Sample Input

4 1

2

3

5

1

5

5 2

1

3

3

3

1

2

3

0 0

Sample Output

CASE# 1:

5 found at 4

CASE# 2:

2 not found

3 found at 3

注:lower_bound(first,end,value);

在【first,end)标记的有序序列中可以插入value,但是不破坏容器顺序的第一个位置,而这个位置标记了一个不小于value的位置。

所以找到p之后要判断是够是value 本身。

同时注意 int p = lower_bound(a,a+n,x) - a ; 要减去数组首地址,因为函数返回值的类型为int * 不能直接转换成int。

#include <iostream>
#in
4000
clude<algorithm>
#include<stdio.h>
#include<cstring>
using namespace std;
const int maxn = 10001;
int a[maxn];
int main()
{
int n,q;
int x;
int cases = 0;
while(scanf("%d%d",&n,&q)==2 && n&&q)
{
printf("CASE# %d:\n",++cases);//这句话不能放在下面的while循环里,否则和样例中输出的格式不一致。
memset(a,0,sizeof(a));//记得每次重置数组
for(int i = 0; i<n; i++)
{
scanf("%d",&a[i]);
}
sort(a,a+n);

while(q--)
{
scanf("%d",&x);//当前要寻找的元素
int p = lower_bound(a,a+n,x) - a ;

if(a[p]==x)
printf("%d found at %d\n",x,p+1);//注意要输出的不是下标,而是位置
else
printf("%d not found\n",x);
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: