您的位置:首页 > 其它

1126. Eulerian Path (25)

2017-11-13 21:55 471 查看
In graph theory, an Eulerian path is a path in a graph which visits every edge exactly once. Similarly, an Eulerian circuit is an Eulerian path which starts and ends on the same vertex. They were first discussed by Leonhard Euler while solving the famous Seven
Bridges of Konigsberg problem in 1736. It has been proven that connected graphs with all vertices of even degree have an Eulerian circuit, and such graphs are called Eulerian. If there are exactly two vertices of odd degree, all Eulerian paths
start at one of them and end at the other. A graph that has an Eulerian path but not an Eulerian circuit is called semi-Eulerian. (Cited from https://en.wikipedia.org/wiki/Eulerian_path)
Given an undirected graph, you are supposed to tell if it is Eulerian, semi-Eulerian, or non-Eulerian.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 2 numbers N (<= 500), and M, which are the total number of vertices, and the number of edges, respectively. Then M lines follow, each describes an edge by giving the two ends of
the edge (the vertices are numbered from 1 to N).

Output Specification:

For each test case, first print in a line the degrees of the vertices in ascending order of their indices. Then in the next line print your conclusion about the graph -- either "Eulerian", "Semi-Eulerian", or "Non-Eulerian". Note that all the numbers in the
first line must be separated by exactly 1 space, and there must be no extra space at the beginning or the end of the line.
Sample Input 1:
7 12
5 7
1 2
1 3
2 3
2 4
3 4
5 2
7 6
6 3
4 5
6 4
5 6

Sample Output 1:
2 4 4 4 4 4 2
Eulerian

Sample Input 2:
6 10
1 2
1 3
2 3
2 4
3 4
5 2
6 3
4 5
6 4
5 6

Sample Output 2:
2 4 4 4 3 3
Semi-Eulerian

Sample Input 3:
5 8
1 2
2 5
5 4
4 1
1 3
3 2
3 4
5 3

Sample Output 3:
3 3 4 3 3
Non-Eulerian


题目没翻译出来。。。。

看每个点的度。

如果每个点的度都是偶数就是Eulerian

如果只有两个点的度是奇数,其他是偶数,就是Semi-Eulerian

另外注意判断图是否联通

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<vector>
#include<set>
#include<queue>
#include<cstring>
#include<map>
using namespace std;
int father[1000];
int find(int x){
if(x==father[x]) return x;
return father[x]=find(father[x]);
}
void Init(int n){
for(int i=1;i<=n;i++) father[i]=i;
}
int main(){
int n,m;
scanf("%d%d",&n,&m);
vector<int> ve[1000];
Init(n);
for(int i=0;i<m;i++){
int a,b;
scanf("%d%d",&a,&b);

ve[a].push_back(b);
ve[b].push_back(a);
a=find(a),b=find(b);
father[a]=b;
}
set<int> s;
int a[1000]={0};
for(int i=1;i<=n;i++) s.insert(find(i));
int len=0;
a[1]=ve[1].size();
printf("%d",a[1]);
if(a[1]%2==1) len++;
for(int i=2;i<=n;i++){
a[i]=ve[i].size();
printf(" %d",a[i]);
if(a[i]%2==1) len++;
}
if(len>2||s.size()!=1) printf("\nNon-Eulerian");
else if(len==0) printf("\nEulerian");
else printf("\nSemi-Eulerian");
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: