您的位置:首页 > 产品设计 > UI/UE

PAT - 甲级 - 1041. Be Unique (20)(Hash散列)

2017-11-13 16:16 465 查看
Being unique is so important to people on Mars that even their lottery is designed in a unique way. The rule of winning is simple: one bets on a number chosen from [1, 104]. The first one who bets on a unique number wins. For
example, if there are 7 people betting on 5 31 5 88 67 88 17, then the second one who bets on 31 wins.

Input Specification:

Each input file contains one test case. Each case contains a line which begins with a positive integer N (<=105) and then followed by N bets. The numbers are separated by a space.

Output Specification:

For each test case, print the winning number in a line. If there is no winner, print "None" instead.
Sample Input 1:
7 5 31 5 88 67 88 17

Sample Output 1:
31

Sample Input 2:
5 888 666 666 888 888

Sample Output 2:
None


#include<cstdio>
#include<algorithm>
using namespace std;

int table[100001];
int a[100001];
int n;
int main(){
fill(table, table+100001, 0);

scanf("%d", &n);
for(int i = 0; i < n; i++){
scanf("%d", &a[i]);
table[a[i]]++;
}
int flag = 0;
for(int i = 0; i < n; i++){
if(table[a[i]] == 1){
printf("%d\n", a[i]);
flag = 1;
break;
}
}
if(!flag) printf("None\n");
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: