您的位置:首页 > 产品设计 > UI/UE

Number Sequence hdu 1711

2017-11-13 09:32 417 查看
[align=left]题目链接:点击打开链接
[/align]
[align=left]Problem Description[/align]
Given two sequences of numbers : a[1], a[2], ...... , a
, and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M].
If there are more than one K exist, output the smallest one.

 

[align=left]Input[/align]
The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate
a[1], a[2], ...... , a
. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].

 

[align=left]Output[/align]
For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.

 

[align=left]Sample Input[/align]

2
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 1 3
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 2 1

 

[align=left]Sample Output[/align]
[align=left]6[/align]
[align=left]-1[/align]
[align=left]
[/align]
[align=left]kmp的模板题,kmp的难点就在于next数组,在写next数组时不要忘记可以把一个串看成两个,比如abcaabcd可以看成主串为abcd,模式串为abca[/align]
[align=left]代码:[/align]
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int n,m;
int a[1000005],b[10005],nextt[10005];
void init()
{
memset(a,0,sizeof(a));
memset(b,0,sizeof(b));
memset(nextt,-1,sizeof(nextt));
}
void get_next(int n)
{
int j=-1,i=0;
while(i<n)
{
if(j==-1||b[j]==b[i])
{
i++;
j++;
nextt[i]=j;
}
else
j=nextt[j];
}
}
int kmp()
{
get_next(m);
int i=0,j=0;
while(i<n&&j<m)
{
if(j==-1||a[i]==b[j])
{
i++;
j++;
}
else
j=nextt[j];
if(j==m)
return i-j+1;
}
return -1;
}
int main()
{
int t;
scanf("%d",&t);
while(t--)
{
init();
scanf("%d%d",&n,&m);
for(int i=0; i<n; i++)
scanf("%d",&a[i]);
for(int i=0; i<m; i++)
scanf("%d",&b[i]);
printf("%d\n",kmp());
}
}


[align=left]
[/align]
[align=left]
[/align]
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: