您的位置:首页 > 大数据 > 人工智能

hdu-1039-Easier Done Than Said?

2017-11-12 12:02 549 查看

Easier Done Than Said?

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 14313 Accepted Submission(s): 6934

Problem Description

Password security is a tricky thing. Users prefer simple passwords that are easy to remember (like buddy), but such passwords are often insecure. Some sites use random computer-generated passwords (like xvtpzyo), but users have a hard time remembering themand sometimes leave them written on notes stuck to their computer. One potential solution is to generate "pronounceable" passwords that are relatively secure but still easy to remember.FnordCom is developing such a password generator. You work in the quality control department, and it's your job to test the generator and make sure that the passwords are acceptable. To be acceptable, a password must satisfy these three rules:It must contain at least one vowel.It cannot contain three consecutive vowels or three consecutive consonants.It cannot contain two consecutive occurrences of the same letter, except for 'ee' or 'oo'.(For the purposes of this problem, the vowels are 'a', 'e', 'i', 'o', and 'u'; all other letters are consonants.) Note that these rules are not perfect; there are many common/pronounceable words that are not acceptable.

Input

The input consists of one or more potential passwords, one per line, followed by a line containing only the word 'end' that signals the end of the file. Each password is at least one and at most twenty letters long and consists only of lowercase letters.

Output

For each password, output whether or not it is acceptable, using the precise format shown in the example.Sample Input
a
tv
ptoui
bontres
zoggax
wiinq
eep
houctuh
end
Sample Output
<a> is acceptable.
<tv> is not acceptable.
<ptoui> is not acceptable.
<bontres> is not acceptable.
<zoggax> is not acceptable.
<wiinq> is not acceptable.
<eep> is acceptable.
<houctuh> is acceptable.
题意: 1.至少有一个元音 2.不能有三个连续的元音,和三个连续的辅音 3.除了 oo和ee不能有其他连续的字母,,满足上面三条输出 is acceptable.否者输出 is not acceptable.

code

#include<string>
#include<iostream>
using namespace std;
bool isok(char a)///判断是否是元音
{
if(a=='a'||a=='e'||a=='i'||a=='o'||a=='u')
return true;
return false;
}
int main()
{
string s;
while(cin>>s){
if(s=="end") break;
int a=0,b=0;
bool ans=true,falg=false;
for(int i=0;i<s.size();i++){
// cout<<s[i]<<endl;
if(isok(s[i])){ falg=true;
// cout<<"有元英"<<endl;
}
if(isok(s[i])){
a++;
b=0;
}else{
b++;
a=0;
}
// cout<<a<<" "<<b<<endl;
if(a>=3||b>=3){
ans=false;
break;
}
if(s[i]!='o'&&s[i]!='e'&&i>0){
if(s[i-1]==s[i]){ans=false;break;}
}
}
if(ans&&falg) cout<<'<'<<s<<'>'<<" is acceptable."<<endl;
else cout<<'<'<<s<<'>'<<" is not acceptable."<<endl;
}
return 0;
}

                                            
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: