您的位置:首页 > 产品设计 > UI/UE

hdu 1711 Number Sequence

2017-11-10 18:18 453 查看
点击打开链接


Number Sequence

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 31372    Accepted Submission(s): 13170


Problem Description

Given two sequences of numbers : a[1], a[2], ...... , a
, and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one
K exist, output the smallest one.

 

Input

The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a
.
The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].

 

Output

For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.

 

Sample Input

2
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 1 3
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 2 1

 

Sample Output

6
-1

KMP算法,得到跳转表(next数组),然后进行匹配。

#include <iostream>
#include <cstring>
#include <cstdio>
const int M=1e4;
const int N=1e6;
int Next[M+10];
int str[N+10];
int mo[M+10];
int n,m;
using namespace std;
void getNext()
{
Next[0]=-1;
int i=0,j=-1;
while(i<m)
{
if(j==-1||mo[i]==mo[j])
{
i++;
j++;
Next[i]=j;
}
else
j=Next[j];
}
}
int main()
{
int T;
scanf("%d",&T);
while(T--)
{
scanf("%d%d",&n,&m);
for(int i=0;i<n;i++)
scanf("%d",&str[i]);
for(int i=0;i<m;i++)
scanf("%d",&mo[i]);
getNext();
int ans=-1;
int i=0,j=0;
while(i<n)//KMP匹配
{
if(j==-1||str[i]==mo[j])
{
i++;
j++;
}
else
j=Next[j];
if(j==m)
{
ans=i-j+1;
break;
}
}

printf("%d\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: