您的位置:首页 > 其它

POJ-3661 Running (线性状态dp)

2017-11-10 16:14 197 查看
Running

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 7212 Accepted: 2716
Description

The cows are trying to become better athletes, so Bessie is running on a track for exactly N (1 ≤ N ≤ 10,000) minutes. During each minute, she can choose to either run or rest for the whole minute.

The ultimate distance Bessie runs, though, depends on her 'exhaustion factor', which starts at 0. When she chooses to run in minute i, she will run exactly a distance of Di (1 ≤ Di ≤ 1,000) and her exhaustion
factor will increase by 1 -- but must never be allowed to exceed M (1 ≤ M ≤ 500). If she chooses to rest, her exhaustion factor will decrease by 1 for each minute she rests. She cannot commence running again until her exhaustion factor reaches
0. At that point, she can choose to run or rest.

At the end of the N minute workout, Bessie's exaustion factor must be exactly 0, or she will not have enough energy left for the rest of the day.

Find the maximal distance Bessie can run.

Input

* Line 1: Two space-separated integers: N and M

* Lines 2..N+1: Line i+1 contains the single integer: Di

Output

* Line 1: A single integer representing the largest distance Bessie can run while satisfying the conditions.

 

Sample Input
5 2
5
3
4
2
10

Sample Output
9


#include <stdio.h>
#include <string.h>
#include <iostream>
using namespace std;
int dp[10001][501][2], a[10001];
int main(){
int n, m;
scanf("%d %d", &n, &m);
for(int i = 1; i <= n; ++i){
scanf("%d", &a[i]);
}
memset(dp, 0, sizeof(dp));
for(int i = 1; i <= n; ++i){
dp[i][1][1] = dp[i - 1][0][0] + a[i];
for(int j = 2; j <= min(i, m); ++j){
dp[i][j][1] = dp[i - 1][j - 1][1] + a[i];
}
dp[i][0][0] = max(dp[i - 1][0][0], dp[i - 1][1][1]);
dp[i][0][0] = max(dp[i][0][0], dp[i - 1][1][0]);
for(int j = 1; j < min(i, m); ++j){
dp[i][j][0] = max(dp[i - 1][j + 1][0], dp[i - 1][j + 1][1]);
}
}
printf("%d\n", dp
[0][0]);
}

/*
题意:
10000分钟,给出第i分钟奶牛可以跑多远,每一分钟奶牛要么休息要么跑步,如果跑步会增加一点疲劳度,
休息会减去一点疲劳度,疲劳度不能超过m,不会低于0.奶牛一旦休息就要一直休息到疲劳度为0时才可以继续
跑步,最后时刻奶牛一定要保持疲劳度为0.问最远可以跑多远。

思路:
线性状态dp,dp[i][j][0]表示前i分钟耗费j个疲劳度且第i分钟为休息状态时的最远距离,dp[i][j][1]表示前
i分钟耗费j个疲劳度且第i分钟为跑步状态时的最远距离。。。然后根据情况讨论一下,线性转移一下就好了。
*/
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  ACM 动态规划 线性dp