您的位置:首页 > 理论基础 > 数据结构算法

数据结构实验之二叉树四:(先序中序)还原二叉树

2017-11-09 21:50 399 查看
Time Limit: 1000MS Memory Limit: 65536KB

Submit Statistic

Problem Description

给定一棵二叉树的先序遍历序列和中序遍历序列,要求计算该二叉树的高度。

Input

输入数据有多组,每组数据第一行输入1个正整数N(1 <= N <= 50)为树中结点总数,随后2行先后给出先序和中序遍历序列,均是长度为N的不包含重复英文字母(区分大小写)的字符串。

Output

输出一个整数,即该二叉树的高度。

Example Input

9

ABDFGHIEC

FDHGIBEAC

Example Output

5

Hint

Author

xam

#include<stdio.h>
#include<stdlib.h>
#include<string.h>
struct node
{
char data;
struct node *lchild,*rchild;
};
char a[55],b[55];
int n;
struct node *BT(char *a,char *b,int n)
{
int k;
struct node *t;
if(n==0) t = NULL;
else
{
t = (struct node *)malloc(sizeof(struct node));
t -> data = a[0];
for(k = 0;k < n;k++)
{
if(b[k]==a[0])
break;
}
t -> lchild = BT(a+1,b,k);
t -> rchild = BT(a+k+1,b+k+1,n-k-1);
}
return t;
}

int depth(struct node *t)
{
int depthval,depthleft,depthright;
if(!t)depthval = 0;
else
{
depthleft = depth(t->lchild);
depthright = depth(t->rchild);
if(depthleft < depthright)
depthval = depthright + 1;
else depthval = 1 + depthleft;
}
return depthval;
}
int main()
{
while(~scanf("%d",&n))
{
struct node *T;
scanf("%s",a);
scanf("%s",b);
T = BT(a,b,n);
printf("%d\n",depth(T));
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  数据结构 二叉树