您的位置:首页 > 其它

1002. A+B for Polynomials (25)

2017-11-09 20:58 309 查看
题目:

This time, you are supposed to find A+B where A and B are two polynomials.

Input

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:K N1 aN1 N2 aN2 ... NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi
(i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10,0 <= NK < ... < N2 < N1 <=1000.

Output

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input
2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output
3 2 1.5 1 2.9 0 3.2


题解:

由于0<=N<=1000,范围较小,把多项式直接用数组存储即可。

代码:

#include <cstdio>
#include <iostream>
#include <cstring>
using namespace std;
int main()
{
double sum[1010];
memset(sum, 0, 1010 * sizeof(double));

int k1, k2, ex;
double coe;
scanf("%d", &k1);
for(int i = 0; i < k1; i++)
{
scanf("%d%lf", &ex, &coe);
sum[ex] += coe;
}
scanf("%d", &k2);
for(int i = 0; i < k2; i++)
{
scanf("%d%lf", &ex, &coe);
sum[ex] += coe;
}

int cnt = 0;
for(int i = 0; i < 1001; i++)
{
if(sum[i] != 0)
cnt++;
}
printf("%d", cnt);
for(int i = 1000; i >= 0; i--)
{
if(sum[i] != 0)
{
printf(" %d %.1lf", i, sum[i]);
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: