您的位置:首页 > 其它

Brackets POJ - 2955 区间dp

2017-11-09 20:32 351 查看
We give the following inductive definition of a “regular brackets” sequence:

the empty sequence is a regular brackets sequence,
if s is a regular brackets sequence, then (s) and [s] are regular brackets sequences, and
if a and b are regular brackets sequences, then ab is a regular brackets sequence.
no other sequence is a regular brackets sequence
For instance, all of the following character sequences are regular brackets sequences:

(), [], (()), ()[], ()[()]


while the following character sequences are not:

(, ], )(, ([)], ([(]


Given a brackets sequence of characters a1a2 …
an, your goal is to find the length of the longest regular brackets sequence that is a subsequence of
s. That is, you wish to find the largest m such that for indices
i1, i2, …, im where 1 ≤
i1 < i2 < … < im ≤
n, ai1ai2 …
aim is a regular brackets sequence.

Given the initial sequence
([([]])]
, the longest regular brackets subsequence is
[([])]
.

Input

The input test file will contain multiple test cases. Each input test case consists of a single line containing only the characters
(
,
)
,
[
, and
]
; each input test will have length between 1 and 100, inclusive. The end-of-file is marked by a line containing the word “end” and should not be processed.

Output

For each input case, the program should print the length of the longest possible regular brackets subsequence on a single line.

Sample Input
((()))
()()()
([]])
)[)(
([][][)
end

Sample Output
6
6
4
0
6


又没想到,----------------

搜了一下是dp入门题,感觉比之前做过的两道题还难想

一天三道区间dp- -

说一下这个题,这个题就是跟着题目解释来就行了

难点就是循环顺序以及dp方程的建立

/*
按照题意
1.如果s是满足条件,
4000
那么【s】,(s)满足条件
2.如果a,b满足条件,ab满足条件,ba满足条件
3.空串满足条件
然后按照题意来就可以了
*/
#include<stdio.h>
#include<algorithm>
#include<string.h>
using namespace std;
char str[120];
int dp[120][120];
int main()
{
while(scanf("%s",str+1))
{
if(str[1]=='e')
break;
int n=strlen(str+1);
memset(dp,0,sizeof(dp));
for(int i=2; i<=n; i++)
{
for(int j=i,k=1; j<=n; j++,k++)
{
if((str[k]=='('&&str[j]==')')||(str[k]=='['&&str[j]==']'))
{
dp[k][j]=dp[k+1][j-1]+2;
}
for(int s=k; s<j; s++)
{
dp[k][j]=max(dp[k][j],dp[k][s]+dp[s+1][j]);
}
}
}
printf("%d\n",dp[1]
);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: