您的位置:首页 > 移动开发

hdu 2830 Matrix Swapping II

2017-11-09 20:16 417 查看
Given an N * M matrix with each entry equal to 0 or 1. We can find some rectangles in the matrix whose entries are all 1, and we define the maximum area of such rectangle as this matrix’s goodness.

We can swap any two columns any times, and we are to make the goodness of the matrix as large as possible.


Input

There are several test cases in the input. The first line of each test case contains two integers N and M (1 ≤ N,M ≤ 1000). Then N lines follow, each contains M numbers (0 or 1), indicating the N * M matrix

Output

Output one line for each test case, indicating the maximum possible goodness.

Sample Input

3 4
1011
1001
0001
3 4
1010
1001
0001


Sample Output

4
2


这道题就是用dp[i][j]表示以i,j为底,包含当前位置的全有1组成的长度,由于可交换,我们对每一行的dp[i]进行排序之后直接遍历计算即可

#include <bits/stdc++.h>
typedef long long ll;
using namespace std;
const int N=1e3+10;
int arr

;
int num
;
char app

;
int main()
{
ios::sync_with_stdio(false);
int n,m;
while(cin>>n>>m)
{
memset(arr,0,sizeof arr);
for(int i=1;i<=n;i++)
cin>>app[i];
int mx=0;
for(int i=1;i<=n;i++)
{
for(int j=0;j<m;j++)
{
if(app[i][j]=='1')
arr[i][j]=arr[i-1][j]+1;
else
arr[i][j]=0;
num[j]=arr[i][j];
}
sort(num,num+m);
for(int j=0;j<m;j++)
mx=max(mx,num[j]*(m-j));
}
cout<<mx<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  子矩阵