您的位置:首页 > 大数据 > 人工智能

HDU-1532 Drainage Ditches(最大流基础)

2017-11-09 19:14 218 查看
Drainage Ditches

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 19639 Accepted Submission(s): 9399

Problem Description

Every time it rains on Farmer John’s fields, a pond forms over Bessie’s favorite clover patch. This means that the clover is covered by water for awhile and takes quite a long time to regrow. Thus, Farmer John has built a set of drainage ditches so that Bessie’s clover patch is never covered in water. Instead, the water is drained to a nearby stream. Being an ace engineer, Farmer John has also installed regulators at the beginning of each ditch, so he can control at what rate water flows into that ditch.

Farmer John knows not only how many gallons of water each ditch can transport per minute but also the exact layout of the ditches, which feed out of the pond and into each other and stream in a potentially complex network.

Given all this information, determine the maximum rate at which water can be transported out of the pond and into the stream. For any given ditch, water flows in only one direction, but there might be a way that water can flow in a circle.

Input

The input includes several cases. For each case, the first line contains two space-separated integers, N (0 <= N <= 200) and M (2 <= M <= 200). N is the number of ditches that Farmer John has dug. M is the number of intersections points for those ditches. Intersection 1 is the pond. Intersection point M is the st
4000
ream. Each of the following N lines contains three integers, Si, Ei, and Ci. Si and Ei (1 <= Si, Ei <= M) designate the intersections between which this ditch flows. Water will flow through this ditch from Si to Ei. Ci (0 <= Ci <= 10,000,000) is the maximum rate at which water will flow through the ditch.

Output

For each case, output a single integer, the maximum rate at which water may emptied from the pond.

Sample Input

5 4

1 2 40

1 4 20

2 4 20

2 3 30

3 4 10

Sample Output

50

#include<bits/stdc++.h>
using namespace std;

const int INF = 0xfffffff;
const int MAXN = 200 + 10;

int flow[MAXN][MAXN];//邻接矩阵存放图。

int mark[MAXN], pre[MAXN];//mark[]标记是否访问过,pre[]记录增广路。
int m, n, f; //f为最大流。

void max_flow()//不断寻找增广路,直到找不到为止,找不到的标志为 mark
==0.
{
while(1)
{
memset(mark, 0, sizeof(mark));
memset(pre, 0, sizeof(pre));
queue<int> Q;
mark[1] = 1;
Q.push(1);//把节点1先入队列
while( !Q.empty() )//如果队列不为空
{
int cnt = Q.front();//把队列首元素给cnt
Q.pop();//弹出
if(cnt == n) //如果队列首即节点n,即找到增广路,跳出。
{
break;//意为找到一条完整的路径(从首节点到n节点)
}
for(int i = 1; i <= n; i++)
{
if(!mark[i] && flow[cnt][i] > 0) //如果节点i 没有被访问过   且  图中 从 首节点到i节点的流量>0
{
mark[i] = 1;//标记节点已经被访问了
Q.push(i);//把节点如队列
pre[i] = cnt;//标记此时走到i节点的增广路是以cnt为首节点
}
}
}
//如果没找到可增广的路,直接跳出.
if( !mark
)
{
break;
}
//计算该增广路最大可增加的流量.
int minx = INF;
for(int i = n; i != 1; i = pre[i])
{
minx = min( flow[pre[i]][i], minx );
}

for(int i = n; i != 1; i = pre[i])
{
flow[pre[i]][i] -= minx; //更新正向流量。
flow[i][pre[i]] += minx; //更新反向流量。
}
f += minx;
}
}

int main()
{
while(scanf("%d %d", &m, &n) != EOF)
{
memset(flow, 0, sizeof(flow));
for(int i = 0; i < m; i++)
{
int u, v, len;
scanf("%d %d %d", &u, &v, &len);
flow[u][v] += len;//重边情况
}
f = 0;
max_flow();
printf("%d\n", f);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: