您的位置:首页 > 产品设计 > UI/UE

PAT甲级 1041. Be Unique (20)

2017-11-09 18:50 399 查看
题目:

Being unique is so important to people on Mars that even their lottery is designed in a unique way. The rule of winning is simple: one bets on a number chosen from [1, 104]. The first one who bets on a unique number wins. For
example, if there are 7 people betting on 5 31 5 88 67 88 17, then the second one who bets on 31 wins.

Input Specification:

Each input file contains one test case. Each case contains a line which begins with a positive integer N (<=105) and then followed by N bets. The numbers are separated by a space.

Output Specification:

For each test case, print the winning number in a line. If there is no winner, print "None" instead.
Sample Input 1:
7 5 31 5 88 67 88 17

Sample Output 1:
31

Sample Input 2:
5 888 666 666 888 888

Sample Output 2:
None

思路:
之前做的思路是按顺序查找是否有unique值,有的输出,无则输出None。但结果证明其会有超时,即使把cin改成scanf,测试点4还是会超时。之后在输入时就利用数组统计次数,但查找时仍需要按照顺序,程序才通过。

代码:

#include<iostream>
#include<vector>
#include<fstream>
using namespace std;

int main()
{

int N;
cin >> N;
vector<int> squeue(N);
int data[10001] = { 0 };
//输入数据,并统计相关次数
for (int i = 0; i < N; ++i)
{
scanf("%d",&squeue[i]);
data[squeue[i]]++;
}
//按顺序查找是否有unique的值
bool flag = 0;
for (int i = 0; i < N; ++i)
{
if (data[squeue[i]] == 1)
{
cout << squeue[i] << endl;
flag = 1;
break;
}
}
//如果没有unique值
if (!flag)
cout << "None" << endl;

system("pause");
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  PAT c++