您的位置:首页 > 其它

并查集 hdu1213 How Many Table 图论500题

2017-11-09 02:10 519 查看


How Many Tables

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 34888    Accepted Submission(s): 17396


Problem Description

Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.

 

Input

The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines
follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.

 

Output

For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.

 

Sample Input

2
5 3
1 2
2 3
4 5

5 1
2 5

 

Sample Output

2
4

 
题目大意:

题目描述的是在生日聚会上,为了保证任意另个相邻的人之间不是陌生人,求最少需要多少张桌子。

题目解析:

这是一个简单的并查集,就是一个模板题,当我看到这个题目的时候第一反应就是用并查集构建,最终求出要建几棵树就好了,很简单的

代码:

#include <iostream>
#include <algorithm>
#include <cstring>
#include <cstdio>
using namespace std;
int p[1005];

struct Edge
{
int u,v;
} edge[1005];

int find(int x)
{
return x==p[x]?x:find(p[x]);
}

int main()
{
//freopen("in.txt","r",stdin);
int T;
cin>>T;
while(T--)
{
int m,n,cnt=0;
cin>>n>>m;
for(int i=0; i<=n; i++)
p[i]=i;
for(int i=1; i<=m; i++)
{
cin>>edge[i].u>>edge[i].v;
int x = find(edge[i].u);
int y = find(edge[i].v);
if(x!=y)
{
p[x] = y;
}
}
for(int i=1;i<=n;i++)
{
if(find(i)==i)
cnt++;
}
cout<<cnt<<endl;
}
return 0;
}

 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  图论500题