您的位置:首页 > 其它

Beat the Spread! POJ - 2301 (水题)

2017-11-08 18:33 423 查看
Beat the Spread! POJ - 2301

Superbowl Sunday is nearly here. In order to pass the time waiting for the half-time commercials and wardrobe malfunctions, the local hackers have organized a betting pool on the game. Members place
their bets on the sum of the two final scores, or on the absolute difference between the two scores. 

Given the winning numbers for each type of bet, can you deduce the final scores? 

Input
The first line of input contains n, the number of test cases. n lines follow, each representing a test case. Each test case gives s and d, non-negative integers representing the sum and (absolute) difference
between the two final scores.

Output
For each test case, output a line giving the two final scores, largest first. If there are no such scores, output a line containing "impossible". Recall that football scores are always non-negative
integers.

Sample Input
2
40 20
20 40


Sample Output
30 10
impossible

code:

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
int main(){
int n;
scanf("%d",&n);
int sum,different;
while(n--){
scanf("%d%d",&sum,&different);
if(different == sum){//如果和和差相同两个一定为零,然后直接下一次循环
printf("0 0\n");
continue;
}
if(different > sum){//差大于和是不可能的
printf("impossible\n");
continue;
}
int a,b;
if((different+sum)%2!=0){//如果和加差不是偶数一定不可能
printf("impossible\n");
continue;
}
a = (different+sum)/2;
b = sum-a;//求a,b即可
if(a<b){//大的数在前面
int t = a;
a = b;
b = t;
}
printf("%d %d\n",a,b);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: