您的位置:首页 > 其它

HDU 5929 Basic Data Structure

2017-11-08 15:42 393 查看
Mr. Frog learned a basic data structure recently, which is called stack.There are some basic operations of stack: 

∙∙ PUSH
x: put x on the top of the stack, x must be 0 or 1. 
∙∙ POP:
throw the element which is on the top of the stack. 

Since it is too simple for Mr. Frog, a famous mathematician who can prove "Five points coexist with a circle" easily, he comes up with some exciting operations: 

∙∙REVERSE:
Just reverse the stack, the bottom element becomes the top element of the stack, and the element just above the bottom element becomes the element just below the top elements... and so on. 
∙∙QUERY:
Print the value which is obtained with such way: Take the element from top to bottom, then do NAND operation one by one from left to right, i.e. If  atop,atop−1,⋯,a1atop,atop−1,⋯,a1 is
corresponding to the element of the Stack from top to the bottom, value=atopvalue=atop nand atop−1atop−1 nand
... nand a1a1.
Note that the Stack will not change after QUERY operation. Specially, if the Stack is empty now,you need to print ” Invalid.”(without quotes). 

By the way, NAND is a basic binary operation: 

∙∙ 0
nand 0 = 1 
∙∙ 0
nand 1 = 1 
∙∙ 1
nand 0 = 1 
∙∙ 1
nand 1 = 0 

Because Mr. Frog needs to do some tiny contributions now, you should help him finish this data structure: print the answer to each QUERY, or tell him that is invalid. 

InputThe first line contains only one integer T (T≤20T≤20),
which indicates the number of test cases. 

For each test case, the first line contains only one integers N (2≤N≤2000002≤N≤200000),
indicating the number of operations. 

In the following N lines, the i-th line contains one of these operations below: 

∙∙ PUSH
x (x must be 0 or 1) 
∙∙ POP 
∙∙ REVERSE 
∙∙ QUERY 

It is guaranteed that the current stack will not be empty while doing POP operation.

OutputFor each test case, first output one line "Case #x:w, where x is the case number (starting from 1). Then several lines follow,  i-th line contains an integer indicating the answer to the i-th QUERY operation. Specially, if the i-th QUERY is invalid,
just print " Invalid."(without quotes). (Please see the sample for more details.) 

Sample Input
2
8
PUSH 1
QUERY
PUSH 0
REVERSE
QUERY
POP
POP
QUERY
3
PUSH 0
REVERSE
QUERY


Sample Output
Case #1:
1
1
Invalid.
Case #2:
0


Hint
In the first sample: during the first query, the stack contains only one element 1, so the answer is 1. then in the second query, the stack contains 0, l
(from bottom to top), so the answer to the second is also 1. In the third query, there is no element in the stack, so you should output Invalid.

双端队列+模拟
#include<cstdio>
#include<queue>
#include<cstring>
#include<algorithm>
using namespace std;
const int N = 1e5 + 10;
const int INF = 0x7FFFFFFF;
const int mod = 1e9 + 7;
const int M = 3e5;
const int low(int x) { return x&-x; }
int T, n, x;
char s
;
int a[N<<3];

int main(){
int cas = 1;
for (scanf("%d",&T);T--;cas++) {
scanf("%d",&n);
int l = M, r= M - 1,now = 1;
printf("Case #%d:\n",cas);
deque<int> b;
while (n--) {
scanf("%s",s);
if (!strcmp(s,"PUSH")) {
scanf("%d",&x);
if (now) {
a[++r] = x;
if (!x) b.push_back(r);
}
else {
a[--l] = x;
if (!x) b.push_front(l);
}
}
else if (!strcmp(s,"REVERSE")) {
now^=1;
}
else if (!strcmp(s,"POP")) {
if (now) {
if (!a[r]) {
b.pop_back();
}
--r;
}
else {
if (!a[l]) {
b.pop_front();
}
++l;
}
}
else {
if (l>r) {
printf("Invalid.\n");
}
else if (b.empty()) {
printf("%d\n",(r-l+1)%2);
}
else if (now == 0) {
if (b.back() == l) printf("%d\n",(r-l)%2);
else printf("%d\n",(r-b.back()+1)%2);
}
else {
if (b.front() == r) printf("%d\n",(r-l)%2);
else printf("%d\n",(b.front()-l+1)%2);
}
}
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: