您的位置:首页 > 其它

Codeforces Round #443 (Div. 1) A. Short Program

2017-11-08 09:39 417 查看
时间限制:1S / 空间限制:256MB

【在线测试提交传送门】

【问题描述】

Petya learned a new programming language CALPAS. A program in this language always takes one non-negative integer and returns one non-negative integer as well.

In the language, there are only three commands: apply a bitwise operation AND, OR or XOR with a given constant to the current integer. A program can contain an arbitrary sequence of these operations with arbitrary constants from 0 to 1023. When the program is run, all operations are applied (in the given order) to the argument and in the end the result integer is returned.

Petya wrote a program in this language, but it turned out to be too long. Write a program in CALPAS that does the same thing as the Petya's program, and consists of no more than 5 lines. Your program should return the same integer as Petya's program for all arguments from 0 to 1023.
该程序设计语言一共能执行三种运算,AND, OR , XOR ,通过一系列运算可以将[0,1023]范围内的整数转换为另外一个整数。现在给出一些转换程序语句,请你将语句缩减为不超过5行,得到和原程序同样的输出。


【输入格式】

The first line contains an integer n (1 ≤ n ≤ 5·10^5) — the number of lines.

Next n lines contain commands. A command consists of a character that represents the operation ("&", "|" or "^" for AND, OR or XOR respectively), and the constant xi 0 ≤ xi ≤ 1023.
第一行,一个整数n (1 ≤ n ≤ 5·10^5) ,表示行数。
接下来n行,每行包含一条命令:一条命令用一个字符代表位运算,分别是"&", "|" or "^",即与、或、抑或,一个常数xi(0 ≤ xi ≤ 1023)。


【输出格式】

Output an integer k (0 ≤ k ≤ 5) — the length of your program.
Next k lines must contain commands in the same format as in the input.
输出包含一个整数K(0 ≤ k ≤ 5) 行,表示程序的的行数;
接下来k行,每行包含一条命令,格式与输入一致。


【输入样例1】

3
| 3
^ 2
| 1


【输出样例1】

2
| 3
^ 2


【输入样例2】

3
& 1
& 3
& 5


【输出样例2】

1
& 1


【样例2解释】

Let x be an input of the Petya's program. It's output is ((x&1)&3)&5 = x&(1&3&5) = x&1. So these two programs always give the same outputs.


【输入样例3】

3
^ 1
^ 2
^ 3


【输出样例3】

0


【提示】

You can read about bitwise operations in https://en.wikipedia.org/wiki/Bitwise_operation.


【解题思路】

考虑每一位,只会存在4种情况:

对于输入的数字的每一位而言,要么是1,要么是0。而这些每一位的数输出之后要么变成了0,要么就变成了1.

(1)0->0,1->0
(2)0->1,1->0
(3)0->0,1->1

(4)0->1,1->1

对于四种情况,我们都可以通过^和|就可以解决,分情况讨论输出即可。

【参考代码】

#include<bits/stdc++.h>
using namespace std;

int n,a,b,p;
string s;
int main(){
cin>>n;
a = 0,b = 1023;
for(int i=0;i<n;i++){
cin>>s>>p;
if(s[0]=='|'){
a|=p;
b|=p;
}else if(s[0]=='^'){
a^=p;
b^=p;
}else{
a&=p;
b&=p;
}
}
int ans1=0,ans2=0;
for(int i=0;i<10;i++){
int a1=a&(1<<i);
int b1=b&(1<<i);
if(a1&&b1){
ans1|=(1<<i);
}
if(a1&&!b1){
ans2|=(1<<i);
}
if(!a1&&!b1){
ans1|=(1<<i);
ans2|=(1<<i);
}
}
cout<<"2"<<endl;
cout<<"| "<<ans1<<endl;
cout<<"^ "<<ans2<<endl;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: