您的位置:首页 > 其它

【bzoj3011】[Usaco2012 Dec]Running Away From the Barn

2017-11-07 13:41 337 查看
Description

It’s milking time at Farmer John’s farm, but the cows have all run away! Farmer John needs to round them all up, and needs your help in the search. FJ’s farm is a series of N (1 <= N <= 200,000) pastures numbered 1…N connected by N - 1 bidirectional paths. The barn is located at pasture 1, and it is possible to reach any pasture from the barn. FJ’s cows were in their pastures this morning, but who knows where they ran to by now. FJ does know that the cows only run away from the barn, and they are too lazy to run a distance of more than L. For every pasture, FJ wants to know how many different pastures cows starting in that pasture could have ended up in. Note: 64-bit integers (int64 in Pascal, long long in C/C++ and long in Java) are needed to store the distance values.

给出以1号点为根的一棵有根树,问每个点的子树中与它距离小于l的点有多少个。

Input

Line 1: 2 integers, N and L (1 <= N <= 200,000, 1 <= L <= 10^18)

Lines 2..N: The ith line contains two integers p_i and l_i. p_i (1 <= p_i < i) is the first pasture on the shortest path between pasture i and the barn, and l_i (1 <= l_i <= 10^12) is the length of that path.

Output

Lines 1..N: One number per line, the number on line i is the number pastures that can be reached from pasture i by taking roads that lead strictly farther away from the barn (pasture 1) whose total length does not exceed L.

Sample Input

4 5

1 4

2 3

1 5

Sample Output

3

2

1

1

OUTPUT DETAILS: Cows from pasture 1 can hide at pastures 1, 2, and 4. Cows from pasture 2 can hide at pastures 2 and 3. Pasture 3 and 4 are as far from the barn as possible, and the cows can hide there.

题解

可并堆,以它到根的距离最大值堆顶,每次判断距离是否小于等于l,否则删除。

代码

#include<cstdio>
#include<algorithm>
#include<cmath>
#include<iostream>
#include<cstring>
#include<queue>
typedef long long ll;
using namespace std;
inline int read()
{
int x=0;char ch=getchar();
while (ch<'0'||ch>'9') ch=getchar();
while (ch>='0'&&ch<='9') x=x*10+ch-'0',ch=getchar();
return x;
}
int n,Head[200005],ret[200005],Next[200005];;
ll l,d[200005],len[200005];
4000
int f[200005],tot,ls[200005],rs[200005],dis[200005];
int ans[200005];
void ins(int u,int v,ll w)
{
ret[++tot]=v;len[tot]=w;
Next[tot]=Head[u];Head[u]=tot;
}
int merge(int a,int b)
{
if (!a) return b;
if (!b) return a;
if (d[a]<d[b]) swap(a,b);
rs[a]=merge(rs[a],b);
f[rs[a]]=a;
if (dis[rs[a]]>dis[ls[a]]) swap(ls[a],rs[a]);
dis[a]=dis[rs[a]]+1;
return a;
}
void dfs(int u)
{
ans[u]=1;
for (int i=Head[u];i;i=Next[i])
{
int v=ret[i];
d[v]=d[u]+len[i];
dfs(v);
ans[u]+=ans[v];
f[u]=merge(f[u],f[v]);
while (d[f[u]]-d[u]>l)
{
ans[u]--;
f[u]=merge(ls[f[u]],rs[f[u]]);
}
}
}
int main()
{
n=read();scanf("%lld",&l);
for (int i=2;i<=n;i++)
{
int f;ll w;
scanf("%d%lld",&f,&w);
ins(f,i,w);
}
for (int i=1;i<=n;i++) f[i]=i;
dfs(1);
for (int i=1;i<=n;i++) printf("%d\n",ans[i]);
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: