您的位置:首页 > 其它

ACM_a letter and a number

2017-11-07 09:43 369 查看


                                                                         a letter and a number

                                                                                                        时间限制:3000 ms  |  内存限制:65535
KB
                                                                                                        难度:1

            描述 we define f(A) = 1, f(a) = -1, f(B) = 2, f(b) = -2, ... f(Z) = 26, f(z) = -26;

Give you a letter x and a number y , you should output the result of y+f(x).

输入 On the first line, contains a number T(0<T<=10000).then T lines follow, each line is a case.each case contains a letter x and a number y(0<=y<1000).
输出 for each case, you should the result of y+f(x) on a line 样例输入
6
R 1
P 2
G 3
r 1
p 2
g 3

样例输出
19
18
10
-17
-14
-4


  代码:           import java.util.Scanner;

           public class Main51_217{

             public static void main(String[] args){  

             Scanner sc=new Scanner(System.in);

                         int a=sc.nextInt();  

                         while(a-->0){ 

                                 char c=sc.next().charAt(0);

                                 int b=sc.nextInt();

                                 if(c<91&&c>64)//char tranform into int

                                              b+=(int)(c-64);

                                  else if(c<123&&c>96)

                                              b+=(int)(c-96)*(-1);

                                 System.out.println(b);

                       }  

            }            }
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  acm