您的位置:首页 > 其它

hdu 1114 Piggy-Bank 完全背包问题

2017-11-02 20:36 393 查看

Piggy-Bank

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 27803    Accepted Submission(s): 14040


[align=left]Problem Description[/align]
Before ACM can do anything, a budget must be prepared and the necessary financial support obtained. The main income for this action comes from Irreversibly Bound Money (IBM). The idea behind is simple. Whenever some ACM member has
any small money, he takes all the coins and throws them into a piggy-bank. You know that this process is irreversible, the coins cannot be removed without breaking the pig. After a sufficiently long time, there should be enough cash in the piggy-bank to pay
everything that needs to be paid.

But there is a big problem with piggy-banks. It is not possible to determine how much money is inside. So we might break the pig into pieces only to find out that there is not enough money. Clearly, we want to avoid this unpleasant situation. The only possibility
is to weigh the piggy-bank and try to guess how many coins are inside. Assume that we are able to determine the weight of the pig exactly and that we know the weights of all coins of a given currency. Then there is some minimum amount of money in the piggy-bank
that we can guarantee. Your task is to find out this worst case and determine the minimum amount of cash inside the piggy-bank. We need your help. No more prematurely broken pigs!

 

[align=left]Input[/align]
The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing two integers E and F. They indicate the weight of an empty pig and of the pig filled
with coins. Both weights are given in grams. No pig will weigh more than 10 kg, that means 1 <= E <= F <= 10000. On the second line of each test case, there is an integer number N (1 <= N <= 500) that gives the number of various coins used in the given currency.
Following this are exactly N lines, each specifying one coin type. These lines contain two integers each, Pand W (1 <= P <= 50000, 1 <= W <=10000). P is the value of the coin in monetary units, W is it's weight in grams.

 

[align=left]Output[/align]
Print exactly one line of output for each test case. The line must contain the sentence "The minimum amount of money in the piggy-bank is X." where X is the minimum amount of money that can be achieved using coins with the given total
weight. If the weight cannot be reached exactly, print a line "This is impossible.".

 

[align=left]Sample Input[/align]

3
10 110
2
1 1
30 50
10 110
2
1 1
50 30
1 6
2
10 3
20 4

 

[align=left]Sample Output[/align]

The minimum amount of money in the piggy-bank is 60.
The minimum amount of money in the piggy-bank is 100.
This is impossible.

 

[align=left]Source[/align]
Central Europe 1999

 

[align=left]Recommend[/align]
Eddy   |   We have carefully selected several similar problems for you:  2191 1059 1024 1160 1025 

#include <algorithm>
#include<iostream>
#include<cstring>
#include<string>
#include<cmath>
using namespace std;
#define nsize 10010
#define INF 0x3f3f3f
int dp[nsize];
int weight[nsize];
int value[nsize];

int main() {
int test;
cin >> test;
while (test--)
{
int a, b, w;
cin >
4000
;> a >> b;
w = b - a;
int n;
cin >> n;
for (int i = 0; i < n; i++) {
cin >> value[i] >> weight[i];
}
//动态规划
//dp[j]表示当前重量j的最小价值
//动态规划注意dp数组的初始化 求最大值dp[j]=0求最小值dp[0]=0,dp[j]=INF
fill(dp, dp + nsize, INF);
dp[0] = 0;
for (int i = 0; i < n; i++) {
for (int j = weight[i]; j <= w; j++) {
dp[j] = min(dp[j], dp[j - weight[i]] + value[i]);
}
}
if (dp[w] < INF)
cout << "The minimum amount of money in the piggy-bank is " << dp[w] <<"."<< endl;
else
cout << "This is impossible." << endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: