您的位置:首页 > 其它

HDU 2020 绝对值排序(water)

2017-11-02 12:01 363 查看

Problem Description

输入n(n<=100)个整数,按照绝对值从大到小排序后输出。题目保证对于每一个测试实例,所有的数的绝对值都不相等。

Input

输入数据有多组,每组占一行,每行的第一个数字为n,接着是n个整数,n=0表示输入数据的结束,不做处理。

Output

对于每个测试实例,输出排序后的结果,两个数之间用一个空格隔开。每个测试实例占一行。

Sample Input

3 3 -4 2

4 0 1 2 -3

0

Sample Output

-4 3 2

-3 2 1 0

Note

标准库sort函数的cmp很好用

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <vector>
#include <cstring>
#include <string>

using namespace std;
bool cmp(int a, int b)
{
return abs(a) > abs(b);
}
int n, num[111];
int main()
{
// freopen("in.txt", "r", stdin);
while (~scanf("%d", &n) && n)
{
for (int i = 0; i < n; i++)
scanf("%d", &num[i]);
sort(num, num + n, cmp);
for (int i = 0; i < n; i++)
{
printf("%d%c", num[i], i == n - 1 ? '\n' : ' ');
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: