您的位置:首页 > 其它

poj 1200 Crazy Search(hash函数)@

2017-11-01 20:30 344 查看
Crazy Search

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 28212 Accepted: 7869
Description

Many people like to solve hard puzzles some of which may lead them to madness. One such puzzle could be finding a hidden prime number in a given text. Such number could be the number of different substrings of a given size that exist in the text. As you soon
will discover, you really need the help of a computer and a good algorithm to solve such a puzzle. 

Your task is to write a program that given the size, N, of the substring, the number of different characters that may occur in the text, NC, and the text itself, determines the number of different substrings of size N that appear in the text. 

As an example, consider N=3, NC=4 and the text "daababac". The different substrings of size 3 that can be found in this text are: "daa"; "aab"; "aba"; "bab"; "bac". Therefore, the answer should be 5. 

Input

The first line of input consists of two numbers, N and NC, separated by exactly one space. This is followed by the text where the search takes place. You may assume that the maximum number of substrings formed by the possible set of characters does not exceed
16 Millions.
Output

The program should output just an integer corresponding to the number of different substrings of size N found in the given text.
Sample Input
3 4
daababac

Sample Output
5

Hint

Huge input,scanf is recommended.

给出一个字符串,求长度为n的子串的种类数;

解:利用下标记录法,将这m个不同的字符,转换为m进制,将长度为n的字符串当做整数来记录

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <map>
#include <queue>
using namespace std;
const int N = 16e6+10;
char str[1000000];
int hash1
, vis[128];

int main()
{
int n, m;
while(scanf("%d %d %s",&n, &m, str)!=EOF)
{
int cnt=0, k=0;
memset(vis,0,sizeof(vis));
memset(hash1,0,sizeof(hash1));
for(int i=0;str[i];i++)
if(!vis[str[i]]) vis[str[i]]=++k;
int power=1, sum=0;
for(int i=0;i<n;i++)
{
sum=sum*m+vis[str[i]];
power*=m;
}
if(!hash1[sum]) hash1[sum]=1, cnt++;
power/=m;
for(int i=n;str[i];i++)
{
sum=(sum-vis[str[i-n]]*power)*m+vis[str[i]];
if(!hash1[sum]) hash1[sum]=1, cnt++;
}
printf("%d\n",cnt);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: