您的位置:首页 > 其它

poj 1564 Sum It Up

2017-10-31 13:26 375 查看
Language:
Default

Sum It Up

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 8123 Accepted: 4149
Description

Given a specified total t and a list of n integers, find all distinct sums using numbers from the list that add up to t. For example, if t = 4, n = 6, and the list is [4, 3, 2, 2, 1, 1], then there are four different sums that equal 4: 4, 3+1, 2+2, and 2+1+1.
(A number can be used within a sum as many times as it appears in the list, and a single number counts as a sum.) Your job is to solve this problem in general.
Input

The input will contain one or more test cases, one per line. Each test case contains t, the total, followed by n, the number of integers in the list, followed by n integers x 1 , . . . , x n . If n = 0 it signals the end of the input; otherwise, t will be a
positive integer less than 1000, n will be an integer between 1 and 12 (inclusive), and x 1 , . . . , x n will be positive integers less than 100. All numbers will be separated by exactly one space. The numbers in each list appear in nonincreasing order, and
there may be repetitions.
Output

For each test case, first output a line containing `Sums of', the total, and a colon. Then output each sum, one per line; if there are no sums, output the line `NONE'. The numbers within each sum must appear in nonincreasing order. A number may be repeated
in the sum as many times as it was repeated in the original list. The sums themselves must be sorted in decreasing order based on the numbers appearing in the sum. In other words, the sums must be sorted by their first number; sums with the same first number
must be sorted by their second number; sums with the same first two numbers must be sorted by their third number; and so on. Within each test case, all sums must be distinct; the same sum cannot appear twice.
Sample Input
4 6 4 3 2 2 1 1
5 3 2 1 1
400 12 50 50 50 50 50 50 25 25 25 25 25 25
0 0

Sample Output
Sums of 4:
4
3+1
2+2
2+1+1
Sums of 5:
NONE
Sums of 400:
50+50+50+50+50+50+25+25+25+25
50+50+50+50+50+25+25+25+25+25+25

Source
简单DFS搜索。

需要注意的一点:去重因为数据重复而产生的重复值

while(n[i]==n[i+1])  

{  

    i++;  

}  

这一点很重要,把相同数据的都给去掉。

还有就是每次循环查找从当前查找坐标后面开始,这样可以实现不重复。

#include<stdio.h>  

#include<string.h>  

int N,T;  

int flag=0;  

int n[15];  

int temp[15];  

void put()  

{  

    memset(temp,0,sizeof(temp));  

    flag=0;  

    scanf("%d%d",&T,&N);  

    for(int i=0;i<N;i++)  

        scanf("%d",&n[i]);  

}  

void dfs(int x,int y,int z)  

{  

    if (x==0)  

    {  

        flag=1;  

        for(int i=0;i<z;i++)  

        {  

            if(i!=z-1)  

                printf("%d+",temp[i]);  

            else  

                printf("%d\n",temp[i]);  

        }  

        return ;  

    }  

    for(int i=y;i<N;i++)  

    {  

  

        if(x-n[i]>=0)  

        {  

            temp[z]=n[i];  

            dfs(x-n[i],i+1,z+1);  

        }  

        while(n[i]==n[i+1])  

        {  

            i++;  

        }  

    }  

}  

  

int main()  

{  

    while(1)  

    {  

        put();  

        if(N==0)  

            break;  

        printf("Sums of %d:\n",T);  

        dfs(T,0,0);  

        if(flag==0)  

        {  

            printf("NONE\n");  

            continue;  

        }  

    }  

内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: