您的位置:首页 > 产品设计 > UI/UE

hdu 1005 Number Sequence(找规律)

2017-10-30 21:57 411 查看


Number Sequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 181457    Accepted Submission(s): 45078


Problem Description

A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).

 

Input

The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.

 

Output

For each test case, print the value of f(n) on a single line.

 

Sample Input

1 1 3
1 2 10
0 0 0

 

Sample Output

2
5

 

Author

CHEN, Shunbao

 

Source

ZJCPC2004

 

Recommend

JGShining   |   We have carefully selected several similar problems for you:  1008 1021 1019 1009 1012 

代码:

#include<iostream>
#include<cstdio>
using namespace std;
int f[100000005];
int main()
{
int a,b,n,i,j;
while(cin>>a>>b>>n&&a&&b&&n)
{
int s=0;//周期
f[1]=1;
f[2]=1;
for(i=3;i<=n;i++)
{
f[i]=(a*f[i-1]+b*f[i-2])%7;
for(j=2;j<=i-1;j++)
{
if(f[i]==f[j]&&f[i-1]==f[j-1])
{
s=i-j;
break;
}
}
if(s>0) break;  //注意,不然还得循环
}
if(s>0)
{
f
=f[(n-j)%s+j];
}
cout<<f
<<endl;

}
return 0;
}


不知为什么错

#include<iostream>
#include<cstdio>
using namespace std;
int f[100000005];
int main()
{
int a,b,n,i,j;
while(cin>>a>>b>>n&&a&&b&&n)
{
int s=0;//周期
f[0]=0;
f[1]=1;
f[2]=1;
for(i=3;i<=n;i++)
{
f[i]=(a*f[i-1]+b*f[i-2])%7;
for(j=1;j<=i-1;j++)
{
if(f[i]==f[j]&&f[i-1]==f[j-1])
{
s=i-j;
break;
}
}
if(s>0) break;  //注意,不然还得循环
}
if(s>0)
{
f
=f[n%s];
}
cout<<f
<<endl;

}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: