您的位置:首页 > 编程语言 > C语言/C++

ZOJ Problem Set - 1074 To the Max (最大和子矩阵 dp)

2017-10-25 16:12 591 查看
Time Limit:1000MS     Memory
Limit:10000KB     64bit IO Format:%I64d & %I64u
 

Description

Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1*1 or greater located within the whole array. The sum of a rectangle is the sum
of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle. 

As an example, the maximal sub-rectangle of the array: 

0 -2 -7 0 

9 2 -6 2 

-4 1 -4 1 

-1 8 0 -2 

is in the lower left corner: 

9 2 

-4 1 

-1 8 

and has a sum of 15. 

Input

The input consists of an N * N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed
by N^2 integers separated by whitespace (spaces and newlines). The
4000
se are the N^2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as
large as 100. The numbers in the array will be in the range [-127,127].

Output

Output the sum of the maximal sub-rectangle.

Sample Input

4
0 -2 -7 0 9 2 -6 2
-4 1 -4  1 -1

8  0 -2


Sample Output

15


题意:把一个具有最大和的子矩阵作为最大子矩阵。

本题直接模拟是要超时的,需要用到动态规划算法。

设数组b表示数组a的i~j行,对应列元素的和。

然后对数组b计算最大子段和,这就将二维动态规划问题转化为了一维动态规划问题。

#include <cstdio>
#include <cstring>
#include <iostream>
using namespace std;
int n,sum,f,max;
int b[20000];
int dp[150][150];

int main(){
f=-10;
cin>>n;
for(int i=0;i<n;i++)
{
cin>>dp[i][j];
}
for(int k=0;k<n;k++)//行
{
memset(b,0,sizeof(b));
for(int i=k;i<n;i++)//
{
for(int j=0;j<n;j++)//每行
b[j]+=dp[i][j];

for(int i=0;i<n;i++)
{
if(sum<0)
sum=b[i];
else
sum+=b[i];
if(max<sum)
max=sum;
}
if(f<max)
f=max;
}
}
cout<<f<<endl;
return 0;
}


三重循环,算法时间复杂度为O(n^3).
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  C++ 算法