您的位置:首页 > 产品设计 > UI/UE

HDU - 6025 Coprime Sequence (gcd前缀后缀处理)

2017-10-23 19:05 399 查看
Do you know what is called ``Coprime Sequence''? That is a sequence consists of nnpositive
integers, and the GCD (Greatest Common Divisor) of them is equal to 1. 

``Coprime Sequence'' is easy to find because of its restriction. But we can try to maximize the GCD of these integers by removing exactly one integer. Now given a sequence, please maximize the GCD of its elements.

InputThe first line of the input contains an integer T(1≤T≤10)T(1≤T≤10),
denoting the number of test cases. 

In each test case, there is an integer n(3≤n≤100000)n(3≤n≤100000) in
the first line, denoting the number of integers in the sequence. 

Then the following line consists of nn integers a1,a2,...,an(1≤ai≤109)a1,a2,...,an(1≤ai≤109),
denoting the elements in the sequence.
OutputFor each test case, print a single line containing a single integer, denoting the maximum GCD.
Sample Input
3
3
1 1 1
5
2 2 2 3 2
4
1 2 4 8


Sample Output
1
2
2


这个题意呢,给你一系列质序列(就是他们的最大公约数为1)。然后呢,让你选一个数然后去掉,让他们的最大公约数变的最大。

思路:一看数据那么大,肯定不能直接算。但是又要将所有的组合都要算一遍,怎么办呢?用数组存头到尾存一遍他们的最大公约数,用pre[]代替好了,然后呢,怎样去一个数呢,把他“隔”过去好了,问题是怎样实现呢。

1.用·s[]逆着存一遍。

2、如果求去掉下标为i的数字后整个数列的gcd,直接将该数字前的所有数字的gcd(prefix[i-1])和该数字后所有数字的gcd(s[i+1])再求一下gcd就好了。
代码如下:

#include<stdio.h>
#include<algorithm>
#include<string.h>
using namespace std;
int a[100005],n;
int pre[100005],s[100005];

int gcd(int a,int b)
{
if(b==0)
return a;
else return gcd(b,a%b);
}

int main()
{
int t;
scanf("%d",&t);
while(t--)
{
scanf("%d",&n);
for(int i=0; i<n; i++)
scanf("%d",&a[i]);
pre[0]=a[0];

for(int i=1; i<n; i++)
{
pre[i]=gcd(pre[i-1],a[i]);
}

s[n-1]=a[n-1];

for(int i=n-2; i>=0; i--)
{
s[i]=gcd(s[i+1],a[i]);
}
int ans=max(s[1],pre[n-2]);

for(int i=1; i<n-1; i++)
{
ans=max(ans,gcd(pre[i-1],s[i+1]));
}
printf("%d\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: