您的位置:首页 > 其它

1042. 字符统计(20)

2017-10-19 19:51 274 查看


1042. 字符统计(20)

时间限制

400 ms

内存限制

65536 kB

代码长度限制

8000 B

判题程序

Standard

作者

CHEN, Yue

请编写程序,找出一段给定文字中出现最频繁的那个英文字母。

输入格式:

输入在一行中给出一个长度不超过1000的字符串。字符串由ASCII码表中任意可见字符及空格组成,至少包含1个英文字母,以回车结束(回车不算在内)。

输出格式:

在一行中输出出现频率最高的那个英文字母及其出现次数,其间以空格分隔。如果有并列,则输出按字母序最小的那个字母。统计时不区分大小写,输出小写字母。
输入样例:
This is a simple TEST.  There ARE numbers and other symbols 1&2&3...........

输出样例:
e 7

#include<iostream>
#include<string>
using namespace std;
int main()
{

int counts[26]={0};
char str1[1000];
gets(str1);
string str=str1;
char a;
int max=0;
for(int i=0;i<str.length();i++)
{
//cout<<(int)str[i]-84<<endl;
if(str[i]>='a' && str[i] <='z')
counts[(int)str[i]-97]++;
if(str[i]>='A' && str[i] <='Z')
counts[(int)str[i]-65]++;
}
for(int j=0;j<26;j++)
{
if(counts[j]>max)
{
max=counts[j];
a=(char)(j+97);
}
}
cout<<a<<" "<<max;
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: