您的位置:首页 > 其它

Molar mass UVA - 1586

2017-10-19 18:41 387 查看
Molar
mass

Description

An organic compound is any member
of a large class of chemical compounds whose molecules contain carbon. The molar
mass of an organic compound is the mass of one mole of the
organic compound. The molar mass of an organic compound
can be computed from the standard atomic weights of the
elements.
When an organic compound is given as a molecular formula, Dr. CHON wants to find its
molar mass. A molecular
formula, such as C3H4O3,
identifies each constituent element by
its chemical symbol and indicates the number of atoms of each
element found in each discrete molecule of that compound. If
a molecule contains more than one atom of a particular element, this quantity is indicated using a subscript after the chemical symbol.
In this problem, we assume that the molecular formula is represented by only four elements, ‘C’
(Carbon), ‘H’ (Hydrogen), ‘O’
(Oxygen), and ‘N’ (Nitrogen) without parentheses.
The following table shows that the standard atomic weights for ‘C’, ‘H’,
‘O’, and ‘N’.
Atomic Name Carbon Hydrogen Oxygen Nitrogen
Standard Atomic Weight 12.01 g/mol 1.008 g/mol 16.00 g/mol 14.01 g/mol
For example, the molar mass of a molecular formula C6H5OH is
94.108 g/mol which is computed by
6 × (12.01 g/mol) + 6 × (1.008
g/mol) + 1 × (16.00 g/mol).
Given a molecular formula, write a program to compute the molar mass of the formula.

Input
Your program is to read from standard input. The input consists of T test
cases. The number of test
cases T is given in the first line of the input. Each test case is given in a single
line, which contains
a molecular formula as a string. The chemical symbol is given by a capital letter and the length of
the string is greater than 0 and less than 80. The quantity number n which is represented
after the
chemical symbol would be omitted when the number is 1 (2 ≤ n ≤ 99).

Output

Your
program is to write to standard output. Print exactly one line for each test case. The line should
contain the molar mass of the given molecular formula.
Sample Input
4 C
C6H5OH
NH2CH2COOH
C12H22O11

Sample Output
12.010
94.108
75.070
342.296

水题 
 :  直接模拟计算求和即可,有一部分字符串的知识,不过就是模拟了,我写的有点麻烦,但是简单易懂,无非就是求分子质量,代码如下:

#include <stdio.h>
#include <string.h>
int main() {
int N ;
double sum = 0;
char c[105];
scanf("%d",&N);
while(N--) {
sum = 0;
scanf("%s",c);
int m = strlen(c) , t,_;
for(int i = 0; i < m; i++) {
t = 0;
if(c[i] == 'N' || c[i] == 'H' || c[i] == 'O' || c[i] == 'C') {
if(i == m-1) {
t = 1;
if(c[i] == 'H')
sum += 1.008*t;
else if(c[i] == 'C')
sum += 12.01*t;
else if(c[i] == 'O')
sum += 16.00*t;
else
sum += 14.01*t;
break;
}
_ = i;
i++;
for(; i < m; i++) {
if(c[i] <= '9' && c[i] >= '0') {
t = t*10+(c[i]-'0');
if(i == m-1) {
if(c[_] == 'H')
sum += 1.008*t;
else if(c[_] == 'C')
sum += 12.01*t;
else if(c[_] == 'O')
sum += 16.00*t;
else
sum += 14.01*t;
i++;
break;
}
}
else {
if(t == 0) t = 1;
//printf("%c %d\n",c[_],t);
if(c[_] == 'H')
sum += 1.008*t;
else if(c[_] == 'C')
sum += 12.01*t;
else if(c[_] == 'O')
sum += 16.00*t;
else
sum += 14.01*t;
i--;
break;
}
}
}
}
printf("%.3lf\n",sum);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: