您的位置:首页 > 编程语言 > Java开发

【PAT】Digital Library (30)Java实现

2017-10-19 10:28 381 查看


1022. Digital Library (30)

时间限制

1000 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

A Digital Library contains millions of books, stored according to their titles, authors, key words of their abstracts, publishers, and published years. Each book is assigned an unique 7-digit number as its ID. Given any query from a reader, you are supposed
to output the resulting books, sorted in increasing order of their ID's.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<=10000) which is the total number of books. Then N blocks follow, each contains the information of a book in 6 lines:

Line #1: the 7-digit ID number;

Line #2: the book title -- a string of no more than 80 characters;

Line #3: the author -- a string of no more than 80 characters;

Line #4: the key words -- each word is a string of no more than 10 characters without any white space, and the keywords are separated by exactly one space;

Line #5: the publisher -- a string of no more than 80 characters;

Line #6: the published year -- a 4-digit number which is in the range [1000, 3000].

It is assumed that each book belongs to one author only, and contains no more than 5 key words; there are no more than 1000 distinct key words in total; and there are no more than 1000 distinct publishers.

After the book information, there is a line containing a positive integer M (<=1000) which is the number of user's search queries. Then M lines follow, each in one of the formats shown below:

1: a book title

2: name of an author

3: a key word

4: name of a publisher

5: a 4-digit number representing the year

Output Specification:

For each query, first print the original query in a line, then output the resulting book ID's in increasing order, each occupying a line. If no book is found, print "Not Found" instead.
Sample Input:
3
1111111
The Testing Book
Yue Chen
test code debug sort keywords
ZUCS Print
2011
3333333
Another Testing Book
Yue Chen
test code sort keywords
ZUCS Print2
2012
2222222
The Testing Book
CYLL
keywords debug book
ZUCS Print2
2011
6
1: The Testing Book
2: Yue Chen
3: keywords
4: ZUCS Print
5: 2011
3: blablabla

Sample Output:
1: The Testing Book
1111111
2222222
2: Yue Chen
1111111
3333333
3: keywords
1111111
2222222
3333333
4: ZUCS Print
1111111
5: 2011
1111111
2222222
3: blablabla
Not Found


PAT中有一个样例会超内存,网上用Java写的太少了,如果有人有更好的解法,欢迎评论讨论。

package go.jacob.day1018;

import java.util.Arrays;
import java.util.Comparator;
import java.util.List;
import java.util.Scanner;

public class Demo1 {
String[] map = new String[] { "", "title", "author", "keywords", "publisher", "year" };
public static void main(String[] args) {
Scanner sc = new Scanner(System.in);
int n = sc.nextInt();
sc.nextLine();
Book[] books = new Book
;
// 输入处理
for (int i = 0; i < n; i++) {
String ID = sc.nextLine();
String title = sc.nextLine();
String author = sc.nextLine();
String[] keywords = sc.nextLine().split(" ");
List<String> list = (List<String>) Arrays.asList(keywords);
String publisher = sc.nextLine();
int year = Integer.parseInt(sc.nextLine());
// sc.nextLine();// 用来清除缓冲区中残留的空白符
books[i] = new Book(ID, title, author, list, publisher, year);
}
// 以书的ID进行排序
Arrays.sort(books, new Comparator<Book>() {

@Override
public int compare(Book b1, Book b2) {
return b1.ID.compareTo(b2.ID);
}
});
int m = Integer.parseInt(sc.nextLine());
String[] query = new String[m];
for (int i = 0; i < m; i++) {
query[i] = sc.nextLine();
}
for (int i = 0; i < m; i++) {
solve(books, query[i]);
}
sc.close();
}

private static void solve(Book[] books, String string) {
System.out.println(string);
String[] strs = string.split(": ");
int index = Integer.parseInt(strs[0]);
boolean hasElem=false;
if (index == 1) {
hasElem=false;

for(int i=0;i<books.length;i++){
if(books[i].title.equals(strs[1])){
System.out.println(books[i].ID);
hasElem=true;
}
}
}else if(index==2){
hasElem=false;
for(int i=0;i<books.length;i++){
if(books[i].author.equals(strs[1])){
System.out.println(books[i].ID);
hasElem=true;
}
}
}else if(index==3){
hasElem=false;
for(int i=0;i<books.length;i++){
if(books[i].keywords.contains(strs[1])){
System.out.println(books[i].ID);
hasElem=true;
}
}
}else if(index==4){
hasElem=false;
for(int i=0;i<books.length;i++){
if(books[i].publisher.equals(strs[1])){
System.out.println(books[i].ID);
hasElem=true;
}
}
}else if(index==5){
hasElem=false;
for(int i=0;i<books.length;i++){
if(books[i].year.equals(Integer.parseInt(strs[1]))){
System.out.println(books[i].ID);
hasElem=true;
}
}
}
if(!hasElem)
System.out.println("Not Found");
}
}

class Book {
String ID;
String title;
String author;
List<String> keywords;
String publisher;
Integer year;

public Book(String iD, String title, String author, List<String> keywords, String publisher, int year) {
ID = iD;
this.title = title;
this.author = author;
this.keywords = keywords;
this.publisher = publisher;
this.year = year;
}

@Override
public String toString() {
return "Book [ID=" + ID + ", title=" + title + ", author=" + author + ", keywords=" + keywords + ", publisher="
+ publisher + ", year=" + year + "]";
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: